• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Undoing a forums/ to f/ route filter

#1
I initially set up my xenForo with a route filter from forums/ to f/. I decided I may like to undo this, so I changed the route filter to f/ to forums/. However, it did not work, and f/ was not redirected to forums/. Why is this, and is there no way to undo this setting without all the page errors?
 

rainmotorsports

Well-known member
#2
You should be removing the route filter as best as I know it. Default routes don't get route changed TO.

Edit. For seo and link reasons you would have to follow up with an htaccess redirect or the like. There is no fixing the decision in the software.
 

rainmotorsports

Well-known member
#4
The route filter changes default routes to custom ones. Yes it performs a redirect for existing links. But it isn't for redirects back to the original route. If you want the original route I am 99% sure you remove it and as far as redirects go you must do it the old fashioned way.

The route changer just alters the way the route filter in xenforo works. The route for forums is forums. So when you remove the route change to f, f no longer exists and you can't have both because you would create an infinite redirect.
 
#7
Hi, i have the same problem, i have installed xenforo 1.4 in a server with ngnix, ssl, pagespeed module, cloudflare as CDN, and i want change the default route /forums for /foros, how can make the rewrite in nginx?

Thanks for you support.
 

rainmotorsports

Well-known member
#9
Hi how can make the rewrite for change default /forums/ to /foros/ in nginx?

Thanks for you support.
Do you have the friendly URL support added in your config already? Just creating a route filter should do it if so. If not refer to the xenforo manual for friendly URLs in NGINX. I'd paste my config if I wasn't on my phone.
 
#10
Do you have the friendly URL support added in your config already? Just creating a route filter should do it if so. If not refer to the xenforo manual for friendly URLs in NGINX. I'd paste my config if I wasn't on my phone.
Hi, yes, i have enable seo friendly url and works without any problem, but at moment to change forums/ for foros/ in xenforo admin panel appears Error in public site https://myurl.com/foro/

Thanks for you support.
 

Mike

XenForo developer
Staff member
#11
Based on what I'm seeing, you just want to install XenForo into a directory named foro. It doesn't related to route filters like in the initial message.
 
#12
Hi, i have installed xenforo in a folder https://myurl.com/foro/ my forum is a spanish site, for this reason i want change default route forums/ to foros/, so the final url would be something like: https://myurl.com/foro/forums/name-of-the-post/ and i want have https://myurl.com/foro/foros/name-of-the-post/

How can make this change of route? can i delete forums/ prefix o default route? https://myurl.com/foro/name-of-the-post/ , because in xenforo admin panel appears error when make the manual change forums/ to foros/

Thanks for you support.