1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Not a Bug Undefined Index 'use_tfa'

Discussion in 'Resolved Bug Reports' started by batpool52!, Jul 9, 2015.

  1. batpool52!

    batpool52! Well-Known Member

    While trying to upgrade an existing XenForo 1.4.8 board I kept receiving Undefined use_tfa, there are no error stacks available but commenting out the content of the function _assertTfaRequirement under XenForo_ControllerPublic_Abstract fixed the issue for a time.
  2. Mike

    Mike XenForo Developer Staff Member

    Errors are expected before the upgrade runs. Note that you only see the error details if you're an admin or running in debug mode.
    batpool52! likes this.
  3. HWS

    HWS Well-Known Member

    I too get the error and am now not able to log into the ACP to finish the upgrade after having uploaded the files.

    What can I do?

    See also:
    Duplicate - Error upgrade 1.4 > 1.5
  4. Chris D

    Chris D XenForo Developer Staff Member

    You don't need to log into the Admin CP to complete the install. Just go to install/
    Sim and HWS like this.
  5. HWS

    HWS Well-Known Member

    Thank you for your help!

Share This Page