1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Unable to use Mandrill to send emails?

Discussion in 'XenForo Questions and Support' started by jflory7, Feb 17, 2014.

  1. jflory7

    jflory7 Active Member

    Hello XenForo forums,

    I recently started using Mandrill to handle SMTP for my emails from my server's domain, and I wanted to set up Mandrill for use within XenForo to send out system mail and global messages ("Email Users" option).

    However, I've run into a few issues with getting XenForo to work with Mandrill.

    Below are screenshots of the information that I have put into XenForo as well as the server error logs that XenForo gives me.
    [​IMG]
    (The first red box is my email address, and the second box is my API key for Mandrill)

    [​IMG]
    (The errors that XenForo gives me)

    I really would like to use Mandrill to send out emails on my website because it will make my life a little easier since a lot of my emails coming from my website right now are being marked as spam. Is there something that I'm doing wrong? Please let me know!

    Also, I saw this addon in the resources section, but it just seems like something like this should be natively supported in XenForo! But, then again, I'm no expert, so I'm really clueless.

    Any help would be greatly appreciated!
     
  2. Mike

    Mike XenForo Developer Staff Member

    These generally seem to indicate connectivity issues between your server and Mandrill. I suspect it's more likely to be something like an outgoing firewall blocking connections or a limitation with your server (perhaps blocking PHP's stream_socket_client create function?).

    Can you use Gravatar or ReCaptcha?
     
  3. jflory7

    jflory7 Active Member

    Haven't tested ReCaptcha, but Gravatar works. Some kind of firewall setting could be the case, but I'm not sure how to fix or modify that. I have root access to the server where the website is hosted, though.
     
  4. Mike

    Mike XenForo Developer Staff Member

    Well, you could try telnetting to smtp.mandrillapp.com on port 587.

    If you have root access, also check the php.ini for any disable_function values -- you don't want any functions disabled.
     
  5. jflory7

    jflory7 Active Member

    I'm sort of new when it comes to these kinds of thingsā€¦ what do you mean by telnetting?

    Also, I double-checked my php.ini file and nothing is disabled.
    [​IMG]
     
  6. Mouth

    Mouth Well-Known Member

    Type in the below from your server command line, and you should see a successful connection as per below.

    server:~ username$ telnet smtp.mandrillapp.com 587

    Trying 54.220.92.193...
    Connected to smtp.eu-west-1.mandrillapp.com.
    Escape character is '^]'.
    220 smtp.mandrillapp.com ESMTP
     
    gunnerit, jflory7 and MattW like this.
  7. jflory7

    jflory7 Active Member

    Weird... looks like connected properly. Might might be the issue then with connecting via XenForo?

    [​IMG]
     
  8. Mouth

    Mouth Well-Known Member

    maszd, gunnerit and jflory7 like this.
  9. jflory7

    jflory7 Active Member

Share This Page