• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unable To Install Add-Ons

Xarcell

Well-known member
#1
Using fresh install of Beta 2, I am unable to install any add-ons. I get the following error:
A server error occurred. Please try again later.
Add-On's I've tried:
ragtekContactThread.zip
8WayRun.comXenCarta
8WayRun.comXenPorta
TaigaChat
I tried searching for a solution, but couldn't find any positive results.
 

Xarcell

Well-known member
#2
Ok I found in another topic to try adding this to the config file. So I did. All the add-ons give the same error.
$config['debug'] = true;
Now my error says:
SimpleXMLElement::__construct() [simplexmlelement.--construct]: /tmp/phpO0UUrj:1: parser error : Start tag expected, '<' not found
  1. [*]XenForo_Application::handlePhpError()
    [*]SimpleXMLElement->__construct() in XenForo/Model/AddOn.php at line 158
    [*]XenForo_Model_AddOn->installAddOnXmlFromFile() in XenForo/ControllerAdmin/AddOn.php at line 180
    [*]XenForo_ControllerAdmin_AddOn->actionInstall() in XenForo/FrontController.php at line 303
    [*]XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
    [*]XenForo_FrontController->run() in /home/xarcell/public_html/xarchology.com/admin.php at line 13
 

Lawrence

Well-known member
#3
I just downloaded one of the Add-ons you listed above and it installed correctly. It sounds like you do not have the SimpleXML PHP extension installed.
 

Xarcell

Well-known member
#4
I just downloaded one of the Add-ons you listed above and it installed correctly. It sounds like you do not have the SimpleXML PHP extension installed.
Is that something that should be installed on my server?

I'll discuss this with my host.
 

Lawrence

Well-known member
#5
Is that something that should be installed on my server?

I'll discuss this with my host.
It should be as you have XenForo running on your server. :)

Here is what I did to install TaigaChat (in this order):

Downloaded and extracted the zip file to my PC
Using FileZilla, uploaded the contents of the directory in the upload folder.

Once all files were uploaded, I then imported the XML file:

Logging in to my AdminPanel, I then selected the Install Add-on link
Install from uploaded file, I clicked Browse, and selected the addon_TaigaChat XML in the extracted folder on my PC.
 

Xarcell

Well-known member
#6
That worked.

I've been using SMF for so long I assumed I could just upload the compressed package.

TaigaChat seems to be installed, but I do not see it.
 

Xarcell

Well-known member
#9
Thanks for your help, I got my first add-on installed and working.

xenForo has a little bit of a learning curve for me.