1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Unable to get HTTPS working properly

Discussion in 'Troubleshooting and Problems' started by WareManu, Sep 9, 2015.

  1. WareManu

    WareManu Member

    [​IMG]

    As you can see on the picture right there, it is completely messed up. I read at the CloudFlare support that I had to go through the code and make sure the images and JavaScripts is loaded specifically over HTTPS. But I doubt I really have to do that, how can I fix this problem?
     
  2. Tracy Perry

    Tracy Perry Well-Known Member

    Step 1, make sure that you have changed your URL in the ACP to reflect the HTTPS.
    Step 2, enable the Proxy in the ACP.
    Step 3, turn off Rocket expLoader if it is turned on.

    You also need to force your http inbound's to HTTPS protocol, as currently it looks like you are forcing some rewrites to http://www format.
     
    rafass likes this.
  3. nodle

    nodle Well-Known Member

    You may also need to add in your config.php
    Code:
    $_SERVER['HTTPS'] = 'on';
    Depending on your server.
     
    rafass likes this.
  4. WareManu

    WareManu Member

    I am only planning on using Flexible SSL, so I don't have to do all that certificate things.
     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Then your issue is apparently with CloudFlare and it being configured incorrectly. Your best bet for assistance with that will be with their support forum/line.
     
  6. WareManu

    WareManu Member

    What possible could be incorrectly configured?
     
  7. Tracy Perry

    Tracy Perry Well-Known Member

    There were a few headaches (don't remember exactly what they were now it's been a while ago) when I helped a guy do what you are wanting. It took some time researching at cloudflare's support site to get it resolved.
     
  8. nodle

    nodle Well-Known Member

    Are you using full or flexible? Full with require a certificate. If your going free make sure to set it to flexible. Then enable image proxy, then set your board url to https: You may also need to set your .httacess file to redirect to https and you may need to add the code to your config.php that I posted above depending on your server.
     
  9. WareManu

    WareManu Member

    CloudFlare says the problem was caused by using mixed protocols. I'm not really a web developer, so I don't know how to fix it.
    I am using Flexible SSL and I am not sure how to enable image proxy. I tried to set board url to https, and it didn't help.

    EDIT: CloudFlare support ticket: https://support.cloudflare.com/hc/en-us/requests/568812
     
  10. nodle

    nodle Well-Known Member

  11. WareManu

    WareManu Member

    Forcing SSL didn't help. I can still see HTTP links on the tabs. It is not working even a littile bit, it is completely messed up. But, why dosn't the links change to HTTPS when I have changed the basic board information? It dosen't make any sense.
     
  12. nodle

    nodle Well-Known Member

    Did you turn on image proxy?
     
  13. WareManu

    WareManu Member

    Yes.
     
  14. doublespaces

    doublespaces Member

    Was there a solution to this? I don't want to force SSL, only when someone visits from cloudflare when ssl is enabled.
     

Share This Page