• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Unable to get HTTPS working

meos

New member
#1
I have a VPS with Apache with mod_php and nginx as a reverse proxy. A self signed certificate is installed and SSL (https) is forced on my server. Anyway, i'm having problems to generate the right base href.

My site generate always

<base href="http://" />
but i need
<base href="https://" />

I have read this thread http://xenforo.com/community/threads/cannot-change-boardurl.23525/ and this http://sleepycode.com/2010/12/phpmyadmin-using-login-with-nginx-behind-a-https-auth-login/. I have also talked to my hoster. He says fast_cgi does not work on my server.

from me:
Here is the instruction:
>>The simplest solution is just to add this to fastcgi_params.

fastcgi_param HTTPS on;
fastcgi_param HTTP_SCHEME https;
from hoster:
Your VPS does not work as FastCGI server.
Apache with mod_php and nginx as a reverse proxy.
from me:
So is it not possible for me to let the server generate

<base href="https://" />
instead of
<base href="http://" />
?
from hoster:
It is possible. It should be changed in settings of your CMS.
Is there another way to let the server generate the right base href (https) on my VPS?

Because when i change the board url in XenForo it doesn't help at all. I've tried to set it to:

https://mysite.com/board

and

//mysite.com/board

edit: I've sent the url to my hoster and he checked it and said:
You have "base href" tag inside the HTML code of the page.
This part (html code) is not controlled by server. It depends only on setting of your CMS.
I also think now it is for sure a XenForo problem. Because my IPB on the same server/domain works without any problems with SSL and generates automatically the right <base href="https://"> links. ( I have added https:// as board_url in the conf_global.php though )
 

meos

New member
#3

Anthony Parsons

Well-known member
#5
I have tried this already many times. It doesn't help at all.
You asked how to create the correct base href. The above will achieve exactly that. That does not mean it will force https, which is a different matter altogether.

You may have to drop your browser cache as well. I have mine set exactly as described above, and in the source I get:

Code:
<base href="https://www.ptsdforum.org/c/" />
If you want to force https in a specific folder, page or entire site, you have to add the rewrite rule/s to the .htaccess to do it.

I have mine forced https, however; using https in the basic site settings for the site URL sets the base href to https for all relative links without having to call upon the htaccess file to force redirection.
 

meos

New member
#6
Where are you trying this exactly? On a demo installation?

If you need support with this you will need to associate your forum account with your licence and post in the customer support forum: http://xenforo.com/community/forums/troubleshooting-and-problems.24/
No, i'm trying it on my private Server (VPS). I will do this, thanks.

You asked how to create the correct base href. The above will achieve exactly that.
That is the problem. It doesn't work for me. I don't need to force SSL, because it is already forced. But ny XenForo generates only the "http" base ref. This is not a unknown problem, i think it is a XenForo bug, because it works flawless with my IPB. My IPB genrates a "https" base ref without problems. So it it can not be a server problem.

When you look here, he had the same problem. http://xenforo.com/community/threads/cannot-run-forum-through-ssl.23524/

I'm trying to setup my forum through an SSL connection.
Changing the boardUrl to https://www.domain.com/community has no effect, the base href still shows as http.

In fact, changing any URL in there does not affect the site in any way. For example:
http://www.domain.com/forum instead of http://www.domain.com/community
This is exactly my problem. If i change the board url in the ACP, it doesn't change anything. The base ref is still "http".
 

Brogan

XenForo moderator
Staff member
#7
No, i'm trying it on my private Server (VPS). I will do this, thanks.
In that case I've split the posts off and moved them to the customer support forum as a separate thread.

You won't be able to post in this thread until you associate your licence.