1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Unable to edit or delete profile comments - Page not found

Discussion in 'Troubleshooting and Problems' started by Soben, Oct 30, 2014.

  1. Soben

    Soben Member

    When I tried to edit or delete profile posts/comments as a regular member or admin, I'd get this popup error:

    Basically, clicking on edit, delete, or report will result in this error. I've checked user group permission and have tested on default template too.

    The edit link for profile post on this website for example is:

    Code:
    https://xenforo.com/community/profile-posts/20691/edit
    
    and after inspecting mine, it's different:

    Code:
    http://mywebsite.com/profile-posts/edit
    I noticed mine is missing the profile post ID. Any help will be appreciated. Thanks.
     
    Last edited: Oct 30, 2014
  2. Amaury

    Amaury Well-Known Member

    Have you tried with all add-ons disabled?
     
  3. Soben

    Soben Member

    Yes I've tried without the add-ons. No luck though. :(
     
  4. borbole

    borbole Well-Known Member

    What was the latest change you did to your forum prior to getting this issue?
     
  5. Soben

    Soben Member

    Hey guys, thanks for responding. I found the issue. I went through all the files and noticed that one of the files (ProfilePosts.php) was missing from this directory: library/XenForo/Route/Prefix/

    I re-uploaded and it is working now. :)
     
  6. Brogan

    Brogan XenForo Moderator Staff Member

    You may want to investigate how that file was deleted from the server.
     
  7. Soben

    Soben Member

    I've done a server transfer earlier this year and never bother to check since the forum was small. I should've pointed out that the file wasn't really missing but it was 0kb in size so it prob never got transferred fully. Thanks Brogan.
     

Share This Page