• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Twitter Authentication 2.0

No permission to download

guiltar

Well-known member
#1
guiltar submitted a new resource:

Twitter Authentication (version 1.2.0) - Twitter Authentication

INSTALLATION:
1. Upload files
2. Import XML
3. Create twitter application http://dev.twitter.com/apps and put its Consumer Key and Consumer Secret to addon's options.

FEATURES:
1. Registration of a new account via Twitter
2. Association of an old account with Twitter account

NOTES:
1. Complete removal of the addon will leave twitter users without password.
Read more about this resource...
 

ineedhelp

Well-known member
#4
If I ever disable or remove this app, will it also remove/delete all the members who joined using Twitter ? Because, that will be a very big issue/problem...

Can the members set a new password if the app is removed? And login and use the forum as normal ?
 

guiltar

Well-known member
#5
If I ever disable or remove this app, will it also remove/delete all the members who joined using Twitter ? Because, that will be a very big issue/problem...

Can the members set a new password if the app is removed? And login and use the forum as normal ?
Members will be able to reset password if email they set in registration is correct.
Addon doesn't delete members but deletes their twitter association when removed.
 
#6
Got an error :

Code:
Could not retrieve a valid Token response from Token URL: Desktop applications only support the oauth_callback value 'oob' /oauth/request_token?
Any ideas? Thanks

Update : Call back URL needs to be set. Then It Works.
 

Hyperion

Active member
#7
Does this add-on support the stay logged in feature? One of my members who used this said that upon reopening his browser he is no longer logged in. He also says this:

I'm using Safari if that matters.

In my settings on Twitter it says read only access when other forums say read and write access.
 
#9
When ever a new user tries to signup with twitter, he gets this error
Code:
A server error occurred. Please try again later.
Update : Call back URL needs to be set. Then It Works.
Will this make any difference? as i have not set the callback url. If yes then what should be my callback url?
 

guiltar

Well-known member
#10
When ever a new user tries to signup with twitter, he gets this error
Code:
A server error occurred. Please try again later.

Will this make any difference? as i have not set the callback url. If yes then what should be my callback url?
I signed up successfully on your forum :)
Probably site url wasn't set in options.
 
#13
Thanks for this add on, I am having trouble getting it to work though. I installed correctly I'm sure. I set up the twitter app (hopefully I did this correctly). If I'm logged in I can see an option to associate a twitter account, but as an unregistered user I don't see the Twitter button anywhere. Any ideas?
 

guiltar

Well-known member
#14
Thanks for this add on, I am having trouble getting it to work though. I installed correctly I'm sure. I set up the twitter app (hopefully I did this correctly). If I'm logged in I can see an option to associate a twitter account, but as an unregistered user I don't see the Twitter button anywhere. Any ideas?
Could you provide link? If it's your first signature forum, I guess it's a style issue.
Search for 'login_bar_eauth_items' in templates. You should find a hook.
Also check it on default style.
 
#15
Could you provide link? If it's your first signature forum, I guess it's a style issue.
Search for 'login_bar_eauth_items' in templates. You should find a hook.
Also check it on default style.
Thanks, I checked on the default style and it shows up so it's definitely a style issue. ( Yes it's the first link in my sig)I have no clue anything about coding, so I opened a support ticket with the guys who made that style. Hopefully they can help me out.
 
#18
Could you provide link? If it's your first signature forum, I guess it's a style issue.
Search for 'login_bar_eauth_items' in templates. You should find a hook.
Also check it on default style.
I'm having the same issue. It doesn't even show with the default style. Still looking into it.

Edit: I see the <xen:hook name="login_bar_eauth_items"> under the template, but it doesn't seem to work still. The Twitter button did show when I had the old Twitter Authentication plugin installed and disabled... quite odd that it worked then and odd that it won't work now.