1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.1 Trying to upgrade to 1.1 - won't take me to upgrade area

Discussion in 'Installation, Upgrade, and Import Support' started by Jamie Edwards, Dec 4, 2011.

  1. Jamie Edwards

    Jamie Edwards Member

    I am trying to upgrade from 1.0 to 1.1. I have uploaded all of the new files, went to the /install/ area, and the only option I am offered is a new installation. It has detected my existing config.php.

    I've been through the upgrade guide to see if I have missed anything, but it doesn't look like I have.

    Any ideas?
     
  2. Jamie Edwards

    Jamie Edwards Member

    (Yes, I am using the upgrade package)
     
  3. Brogan

    Brogan XenForo Moderator Staff Member

    I am trying to upgrade but it is attempting to do a new installation, how do I proceed without overwriting the existing data?
    It's possible you have uploaded the files from the full package, rather than the upgrade package. Or you have uploaded the correct files but to the wrong location. Check that your data and internal_data directories have not been overwritten. If they have, you will need to restore the files from a backup. To continue with the upgrade, you will need to ensure the correct details are in library/config.php and replace the internal_data/install-lock.php file.

    http://xenforo.com/community/threads/frequently-asked-questions.5183/#post-282417
     
  4. Jamie Edwards

    Jamie Edwards Member

    I am using the upgrade package, data and internal_data have not been overwritten. config.php is correct and intact.
     
  5. Jamie Edwards

    Jamie Edwards Member

    Got there in the end. I am not sure what I did differently, but upload-and-replace the upgrade package worked this time.
     

Share This Page