1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Trying to Post New Thread goes to 'Page Not Found'

Discussion in 'Troubleshooting and Problems' started by Kenneth Holland, Nov 25, 2012.

  1. Kenneth Holland

    Kenneth Holland Active Member

    Hi,

    When I try to create a new thread I get sent to 'Page Not Found'. A couple things happen here:

    1. If it's a pretty short post it will post.

    2. If it's longer it goes to 'Page Not Found' but the error page is from my blog (my forum is in a subdirectory and my blog is in the root).

    My webhost made some changes to the .htaccess and I thought everything was fixed but apparently not.

    http://airnation.net/hangar

    Any help on how to troubleshoot this would be great.

    Ken
     
  2. Kenneth Holland

    Kenneth Holland Active Member

    I wanted to update:

    If I post a thread with a small amount of text (100 words or less approx) it will post, and then I can keep adding to the post using the 'edit' link as much as I want.

    But if I post a larger amount at once, it will throw the error I outlined above.
     
  3. Chris D

    Chris D XenForo Developer Staff Member

    What is the address in the address bar when you get the page not found error?

    What add-ons do you have installed?
     
    Jake Bunce likes this.
  4. Kenneth Holland

    Kenneth Holland Active Member

    It's the same as when I'm posting the thread:

    http://airnation.net/hangar/forums/off-topic.11/create-thread

    Auto Follow on Registration 1.0


    AWeber Integration for XenForo 1.0


    Digital Point Ad Positioning 1.1.0


    Postloop Integration 1.0.2


    [bd] Widget Framework 1.5.4

    I don't think it's an addon because this started when my server admin screwed around with tht .htaccess
     
  5. Chris D

    Chris D XenForo Developer Staff Member

    That'll probably be it then.

    Can you post the htaccess file?
     
    Jake Bunce likes this.
  6. Kenneth Holland

    Kenneth Holland Active Member

    Here you go Chris:

    Code:
    #    Mod_security can interfere with uploading of content such as attachments. If you#    cannot attach files, remove the "#" from the lines below.#<IfModule mod_security.c>#    SecFilterEngine Off#    SecFilterScanPOST Off#</IfModule>ErrorDocument 401 defaultErrorDocument 403 defaultErrorDocument 404 defaultErrorDocument 500 default
    <IfModule mod_rewrite.c>   
    RewriteEngine On   
    #    If you are having problems with the rewrite rules, remove the "#" from the    #    line that begins "RewriteBase" below. You will also have to change the path    #    of the rewrite to reflect the path to your XenForo installation.   
    RewriteBase /hangar   
    #    This line may be needed to enable WebDAV editing with PHP as a CGI.   
    RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]   
    RewriteCond %{REQUEST_FILENAME} -f [OR]   
    RewriteCond %{REQUEST_FILENAME} -l [OR]   
    RewriteCond %{REQUEST_FILENAME} -d   
    RewriteRule ^.*$ - [NC,L]   
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]   
    RewriteRule ^.*$ index.php [NC,L]
    </IfModule>
     
  7. Kenneth Holland

    Kenneth Holland Active Member

    Looks like I got it resolved.

    My webhost had to whitelist a Modsec rule.
     
    Jake Bunce and Chris D like this.
  8. Chris D

    Chris D XenForo Developer Staff Member

    Ahh good, glad you got this sorted (y)
     

Share This Page