• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Trying to implement SVG smilies

MstrfBlng

Active member
#1
Hi guys,

I'm working on my brand new Xenforo installation and I will be migrating from vB5 soon.

I noticed that I'm able to use .svg smilies, but I'm not quite there yet.

I managed to display smilies very well in a post, and they look faboulous on phones and tablets too :)

I did that by adding this in extra.css and editor_contents.css:

img.mceSmilie {
height: 22px;
}

The problem is that when I edit a post the SVG smilie pops up full size in the smilies-bar. Also when adding another svg smilie it will show up full size in the editor box until I save the edited post.

Is there a way to make this work? When I review the CSS for the editor box, it refers to xenforo.css, but adding img.mceSmilie to that css doesn't seem to work.

It would be great if I get this working.

Tim
 

MstrfBlng

Active member
#2
In the mean while I have been digging and I have the solution. I'm able to use SVG smilies now.

I'll make a simple write-up so people that are interested can implement it this way too :)

To be continued
 

JulianD

Well-known member
#3
In the mean while I have been digging and I have the solution. I'm able to use SVG smilies now.

I'll make a simple write-up so people that are interested can implement it this way too :)

To be continued
Do you have a sample of how the smilies look in svg format?
 

MstrfBlng

Active member
#5