1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Transfer vB 4.2 to Xenforo (new domain)

Discussion in 'Installation, Upgrade, and Import Support' started by Ranma1981, Jun 12, 2013.

  1. Ranma1981

    Ranma1981 Member

    Hello,

    please I would like have a clarification regard the transfer of a site.

    I am transfering a vBulletin 4.2 forum from an old domain to Xenforo 1.1.5 (new domain), where I installed Xenforo in a subdomain.

    Now, I already use the Import Tool, and I converted vB to Xenforo 1.1.5, that is correctly located on "forum.newdomain.com".

    Now, I should redirect all my old vB forum with vBSEO, (002 - Hierarchic directory), to Xenforo forum in subdomain.

    On the old domain, vBulletin is installed in the root because I use the rewrite for thread relevance, as on vBSEO.com.

    Using the tool geekpoint online, it suggest me to use this rewrite rules for 002 configurations:

    Code:
    RewriteEngine on
    RewriteRule f[\d]+/.+-([\d]+)/index([\d]+).html showthread.php?t=$1&page=$2 [NC,L]
    RewriteRule f[\d]+/.+-([\d]+)/ showthread.php?t=$1 [NC,L]
    RewriteRule f([\d]+)/index([\d]+).html forumdisplay.php?f=$1&page=$2 [NC,L]
    RewriteRule f([\d]+)/ forumdisplay.php?f=$1 [NC,L]
    So, I should add these rules on old domain, at the .htaccess where are located vBulletin files; right?

    And regard the situation of use Xenforo in subdomain, whate rewrite rules should I use?

    Thank you,
    Regards
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Put those rules in the .htaccess file in the web root on the old domain, where vB was installed.

    You can specify the new domain in the target, like so:

    Code:
    RewriteEngine on
    RewriteRule f[\d]+/.+-([\d]+)/index([\d]+).html http://forum.newdomain.com/showthread.php?t=$1&page=$2 [NC,L]
    RewriteRule f[\d]+/.+-([\d]+)/ http://forum.newdomain.com/showthread.php?t=$1 [NC,L]
    RewriteRule f([\d]+)/index([\d]+).html http://forum.newdomain.com/forumdisplay.php?f=$1&page=$2 [NC,L]
    RewriteRule f([\d]+)/ http://forum.newdomain.com/forumdisplay.php?f=$1 [NC,L]
    
    Then the redirect scripts (showthread.php, forumdisplay.php, etc) would be uploaded to the root of the subdomain where XF is installed.
     
  3. Ranma1981

    Ranma1981 Member

    Hello Jack,

    should I copy showthread.php and forumdisplay.php (of my vB 4.2 version) in the root of subdomain where XF is installed?

    Or should I download other version of these files?

    Thanks!
     
    Last edited: Jun 13, 2013
  4. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  5. Ranma1981

    Ranma1981 Member

    Hello Jake,

    I followed the instructions, upload last version of redirection script files (1.6 v) and I use the code for vBSEO urls.

    But I found any problems. Could you help me to resolve please?

    Otherwise, I can't finish the migration of my community to Xenforo.

    The problems are:

    Forum / Thread paginations

    When a forum or thread is divide in more pages /1, /2, /3, it is not redirect correctly on Xenforo.

    Example:
    These type of url's give 404 errors.

    Members


    Redirects for members doesnt' work. On my old forum I have this type of url:
    They, are not redirected on Xenforo. These type of url's give 404 errors.

    Code that I am using:

    Code:
    RewriteEngine on
    RewriteRule f[\d]+/.+-([\d]+)/index([\d]+).html http://forum.newdomain.com/showthread.php?t=$1&page=$2 [NC,L]
    RewriteRule f[\d]+/.+-([\d]+)/ http://forum.newdomain.com/showthread.php?t=$1 [NC,L]
    RewriteRule f([\d]+)/index([\d]+).html http://forum.newdomain.com/forumdisplay.php?f=$1&page=$2 [NC,L]
    RewriteRule f([\d]+)/ http://forum.newdomain.com/forumdisplay.php?f=$1 [NC,L]
    Thank you Jake,
    Regards
     
    Last edited: Jun 21, 2013
  6. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

  7. Ranma1981

    Ranma1981 Member

    Hello Jake,

    Sorry, I have again any problems.

    a) Now, thread paginations works well, but I have the same problem of pagination, with the pagination of forums.

    Example:
    It give 404 erros.

    b)
    I tried the code for members, but it seems doesn't work.

    I upload member_redirect file on the root of subdomain where is XF.

    My new Xenforo forum is installed in a subdomain (of new domain), so I modified the URL inside your file:

    Code:
    if ($userId)
    {
        header ('HTTP/1.1 301 Moved Permanently');
        header ('Location: [B]http://forum.mysite.it/members/[/B]' . $userId);
    }
    else
    {
        echo 'user not found';
    }
    And I add the new rewrite rule on the root of my old vB forum:

    Code:
    RewriteRule ^members/([^\.]+)\.html$ http://forum.mynewsite/member_redirect.php?username=$1 [R=301,L]
    What is the error?

    Thanks
     
  8. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    @Ranma1981

    a) You need to make a similar change to the forumdisplay.php file.

    b) The example profile URL you gave is different:

    http://www.mysite.it/members/the-stroker-/

    There is no .html so you need to change the rewrite:

    Code:
    RewriteRule ^members/([^/]+)/$ http://forum.mynewsite/member_redirect.php?username=$1 [R=301,L]
    
     
  9. Ranma1981

    Ranma1981 Member

    Hello Jake :)

    Ok for paginations of forums! :)

    Ok also for members redirect...but not at 100%. I noted that any profiles are not redirect correctly, I think that the problem is related at any strange characters, dot and space inside the username. Do you have some fix also for this?

    Here some example for you:

    Screenshot

    Member: goccia

    vB: www.mysite.it/members/goccia/
    XF: forum.mysite.it/members/goccia.ID/ (OK)

    Member: luxs.82

    vB: www.mysite.it/members/luxs-82/
    XF: forum.mysite.it/member_redirect.php?username=luxs-82 (ERROR)

    Member: Monica Ghellere

    vB: www.mysite.it/members/monica-ghellere/
    XF: forum.mysite.it/member_redirect.php?username=monica-ghellere (ERROR)

    Member: lyli@

    vB: www.mysite.it/members/lyli-/
    XF: forum.mysite.it/member_redirect.php?username=lyli- (ERROR)

    Member: #Elisa Uchiha@

    vB: www.mysite.it/members/-elisa-uchiha-/
    XF: forum.mysite.it/member_redirect.php?username=-elisa-uchiha- (ERROR)

    Member: !!c-18!!

    vB: www.mysite.it/members/-c-18-/
    XF: forum.mysite.it/member_redirect.php?username=-c-18- (ERROR)

    Thank you for your help Jake
     
  10. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That is expected because vBSEO modifies some characters for the URLs. If you figure out how to reverse the changes then you can program it in. This requires knowing what string operations vBSEO uses on the usernames.
     
  11. Ranma1981

    Ranma1981 Member

    Hello Jake,

    thank you!

    I enabled the redirect..it works quite well.

    Please, another info. I should also redirected the first level of domain, olddomain.it to newdomain.it;

    What code shoul I add in the .htaccess?

    I found many codes on this site, but when I try to add one on them on my htaccess, the other redirect of forum and thread's, stop to works well.

    Thanks!
     
  12. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Are both domains parked on the same server as both vB and XF? Or is this an old domain that was only used for vB?
     
  13. Ranma1981

    Ranma1981 Member

    No, the domains are on different servers.

    On the old, I have: vBulletin Suite (portal) + vB forum (/forum)

    On the new, I have: Wordpress (portal) + Xenforo (on subdomain)

    I already write hundreds and hundreds of custom rules to redirect well the article on the old Cms to the new WP homepage, I need only a rules to redirect also the old homepage (and if possible), all the pages not found of the old domain, to the domain (for example tags and member profiles, with strange characters).

    For the forum I used:

    Redirect 301 /forum http://forum.newsite.it/ (OK)

    But if I use a similar rule for the home, many forums and thread redirect, stop to work

    Redirect 301 / http://www.newsite.it/
     
  14. Ranma1981

    Ranma1981 Member

    I tried also all the rules showed on this site, but nothing. Than the redirects of sections and threads, stop to works well.

    Method 1:
    Options +FollowSymlinks
    RewriteEngine On
    RewriteCond %{HTTP_HOST} ^olddomain.com [NC]
    RewriteRule ^(.*)$ http://newdomain.com/$1 [L,R=301]

    RewriteCond %{HTTP_HOST} ^www.olddomain.com [NC]
    RewriteRule ^(.*)$ http://newdomain.com/$1 [L,R=301]

    Method 2:

    Options +FollowSymlinks
    RewriteEngine On
    RewriteCond %{HTTP_HOST} \olddomain.com$
    RewriteRule ^(.*)$ http://newdomain.com/$1 [R=301,L]

    Method 3:
    Options +FollowSymLinks
    RewriteEngine on
    RewriteRule (.*) http://www.newdomain.com/$1 [R=301,L]

    Method 4:
    Redirect 301 / http://www.newdomain.com/
     
  15. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Then I think I already answered the question in this previous post:

    http://xenforo.com/community/threads/transfer-vb-4-2-to-xenforo-new-domain.52384/#post-560653

    If that isn't working for you then I need exact URLs of a thread on both vB and XenForo so I can create exact instructions for you.
     
  16. Ranma1981

    Ranma1981 Member

    I already using that code, and it works well for all, except for the old homepage.

    You can check online:

    Old domain:

    Home: p2psin.it
    Forum: p2psin.it/forum/

    New domain:

    Home: tech-magazine.it
    Forum: forum.tech-magazine.it

    If you play the command "cache:" from Google, you can see that all pages works well, except if you point on the home of old domain. That page, is not redirect.

    I need to redirect it (and p2psin.it/index.php) do not miss pagerank on the Web.
     
  17. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    In the .htaccess file in the web root of old domain:

    Code:
    RewriteRule ^$ http://tech-magazine.it/ [R=301,L]
    
    In the .htaccess file in the /forum directory of old domain:

    Code:
    RewriteRule ^$ http://forum.tech-magazine.it/ [R=301,L]
    
     
  18. Ranma1981

    Ranma1981 Member

    Nice Jack! It works perfectly.

    Please, I noted any problems with the redirect of "last posts", that are on the right side column, in the forumhome of old domain.

    For example, thread of this type:

    1) http://www.p2psin.it/f173/virgilio-banner-62890-post106721/#post106721
    2) http://www.p2psin.it/f171/prezzo-ho...ionale-webspazio-62969-post106913/#post106913

    They are not redirect, to the respective thread on Xenforo, but at the category.

    Do you have a fix also for this?

    Thank you for your great help Jake
     
  19. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Code:
    RewriteEngine On
    
    RewriteRule ^[^/]+/.+-post([0-9]+)/$ http://forum.tech-magazine.it/showpost.php?p=$1 [R=301,L]
    
     
  20. Ranma1981

    Ranma1981 Member

    Hello Jake,

    thank you, with your help I transferred with success my forum to Xenforo ;)

    Please, I noted that after some months, Webmaster Tools of Google adviced me some strange mistakes, perhaps when I am tranfering the forum and set the rewrite rules. So, only to fix these errors form GWT, I need to redirect these urls:

    1) From:

    http://forum.mysite.it/msn-messenger/34840-eminem-skin-per-msn-messenger.html

    To:

    http://forum.mysite.it/threads/eminem-skin-per-msn-messenger.34840/

    In the example there is "msn-messenger", the name of a my category on the forum; but I have other errors, with different category name. Is possible set a generic rule to fix the errors from all categories?

    Can you help me to correct these errors?

    Thank you! :)
     

Share This Page