MG 1.1 Transcoding not working?

#1
I installed the newest version of MG on the newest version of Xenforo. My host installed the ffmeg on my VPS. When attempting to upload a 11 second wmv movie from my computer I received a message to the effect that the video could not be processed and to try another video. I adjusted the path to PHP which allowed the movie to be uploaded and also created a thumbnail. After this is said the video needed to be processed and I would receive notification when complete. I am not receiving any message and the video is not being display and so I think not created? I would think that because I saw a thumbnail after uploading the video that ffmeg was doing what it is supposed to although I do not know that to be a fact.

Any advice on how to proceed on troubleshooting the issue?

Thanks, Brian
 
#2
Here are 2 pictures from where the process seems to work to. A notification is not being sent nor is the video being displayed.

thumbnail.jpg
processing.jpg
 

Chris D

XenForo developer
Staff member
#5
Something is causing those entries to fail somewhere. Assuming there is no entries in the Server Error Log anywhere that explains this, it might be worth just starting again.

Delete the two entries from the transcode queue table and then try to upload one of the videos again. Does it move into the "processing" state at all if you look in the database?

If it still doesn't work, a few things to check:
1) Is the PHP binary path correct?
2) Is the FFmpeg path correct?
3) What version of FFmpeg?
4) Do you have any disabled PHP functions such as exec?
 
#6
FFmpeg version is 2.6.8

I do not believe I have any disabled functions. Would need to figure out how to tell.

I deleted the two entries and then uploaded the same 11 second wmv something like 16 MB . That file is now in the queue that I just cleared.

These are the entries I got from tail -f command.

163.172.66.48 - - [02/Mar/2017:17:08:57 +0000] "GET /index.php?forums/forum-seven.7/&order=view_count HTTP/1.1" 404 12584 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
23.95.252.79 - - [02/Mar/2017:17:10:03 +0000] "GET / HTTP/1.0" 200 14802 "http://www.victoriouschristians.com/" "Mozilla/5.0 (Windows NT 6.2; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0"
164.132.161.25 - - [02/Mar/2017:17:10:17 +0000] "GET /programs/xenforo/styles/Peacy%20Keen/149/Upload/styles/Victorious-Christians/uix/fonts/fontawesome-webfont.eot HTTP/1.1" 404 12562 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
77.75.76.160 - - [02/Mar/2017:17:12:49 +0000] "GET /robots.txt HTTP/1.1" 404 208 "-" "Mozilla/5.0 (compatible; SeznamBot/3.2; +http://napoveda.seznam.cz/en/seznambot-intro/)"
77.75.76.160 - - [02/Mar/2017:17:12:50 +0000] "GET /index.php?posts/21/ HTTP/1.1" 404 12563 "-" "Mozilla/5.0 (compatible; SeznamBot/3.2; +http://napoveda.seznam.cz/en/seznambot-intro/)"
163.172.66.16 - - [02/Mar/2017:17:16:34 +0000] "GET /bible/john/8:57/ HTTP/1.1" 404 12497 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
66.249.64.113 - - [02/Mar/2017:17:19:03 +0000] "GET /index.php?threads/forum-six-message.7/ HTTP/1.1" 404 12577 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
163.172.66.97 - - [02/Mar/2017:17:19:35 +0000] "GET /programs/xenforo/mods/live%20feed%20activity/LiveFeed/upload/library/Milano/LiveFeed/ControllerPublic/error_log HTTP/1.1" 404 12548 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
164.132.161.69 - - [02/Mar/2017:17:21:50 +0000] "GET /index.php?bible/mark/14:8/ HTTP/1.1" 404 12502 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
163.172.66.149 - - [02/Mar/2017:17:22:53 +0000] "GET /bible/romans/2:29/ HTTP/1.1" 404 12486 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
66.249.64.117 - - [02/Mar/2017:17:24:04 +0000] "GET /posts/6/ HTTP/1.1" 404 12555 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.64.182 - - [02/Mar/2017:17:24:21 +0000] "GET /posts/1/ HTTP/1.1" 301 - "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
66.249.64.186 - - [02/Mar/2017:17:24:22 +0000] "GET /threads/how-do-we-pray.1/ HTTP/1.1" 200 16040 "-" "Mozilla/5.0 (compatible; Googlebot/2.1; +http://www.google.com/bot.html)"
163.172.66.120 - - [02/Mar/2017:17:24:28 +0000] "GET /bible/john/3:25/ HTTP/1.1" 404 12496 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
51.255.65.17 - - [02/Mar/2017:17:24:55 +0000] "GET /index.php?bible/genesis/14:17/ HTTP/1.1" 404 12508 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
163.172.66.74 - - [02/Mar/2017:17:25:27 +0000] "GET /bible/genesis/40:23/ HTTP/1.1" 404 12501 "-" "Mozilla/5.0 (compatible; AhrefsBot/5.2; +http://ahrefs.com/robot/)"
 

Chris D

XenForo developer
Staff member
#8
If you can open a ticket we will look into this in more detail. Please include an Admin CP login, PhpMyAdmin login and FTP if possible.
 
#10
Regrettably I have moved to another VPS which has resulted in another issue.

I installed ffmpeg 2.6.8 and php exec is enabled and have tried various paths for php and ffmeg. The result is creating a thumbnail and creating an entry in the transcoding queue. When I installed ffmpeg I ran one of those test the install commands availabe which resulted in saving both the new and transcoded file. I have tried several php versions also.

Is it more likely a php issue or ffmpeg if the thumbnail gets created and an entry in the transcoding queue created?
 

Chris D

XenForo developer
Staff member
#11
Probably worth going through the same process as before.

If you can submit a ticket again with all the relevant details. Shell access was actually useful last time which was possible through the cPanel credentials so if you no longer use cPanel then please provide a separate ssh login if possible.
 
Top