• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Browser issue Top Navigation Bar falling out of place

Affected version
Current xenforo.com version.

katsulynx

Well-known member
#1
I noticed a weird behaviour here on xenforo.com. When opening the navigation menu in the forum index while scrolled down, the top Navigation bar will clip out of place (see Screenshot). This happens exclusively on the forum index as far as I can tell and only here on xenforo.com, not on my own page.

Screenshot_2017-10-04-17-13-59.png

Spec:
Screenshot_2017-10-04-17-33-21.png
 

Mike

XenForo developer
Staff member
#2
I can actually reproduce this, though I have no idea why it's just this page. It looks like toggling the body overflow hidden off resolves the issue.

It appears to happen on desktop Chrome as well, so it's looking like a browser issue right now.
 

Mike

XenForo developer
Staff member
#4
This looks like it may be a position sticky bug in Chrome (which there were a number of in older versions). I can't reproduce this in Chrome beta (62) or Canary (63), so I suspect it's resolved by a bug fix there, so I think we'll leave this as a browser bug then that will become less relevant fairly soon.
 
#5
I too have this issue in my android app which work on webview and chrome view.

On mobile firefox browser, after closing page, when thumbnail small boxes shown on blank page, i observed shifted navigation bar in that generated thumbnail.

On mobile when actually opening site, i never get issue.