• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.3 [thread=xxx] and [post=xxx]

imthebest

Well-known member
#1
I'm migrating from vB 3.8 where the system is configured to start a new thread on the staff forums whenever a new report is generated by a member. Problem is that all of those report threads don't look that good in xenForo:

Affected Thread: [thread=xxx]This is the thread title[/thread]
Link to the Post: [post=xxx]here[/post]

What are my choices?
 

xf_phantom

Well-known member
#2

imthebest

Well-known member
#4
While the add-on is working fine I would prefer to manage this without an add-on but with a simple custom BB code. What should I put on HTML replacement and PHP callback?
 

imthebest

Well-known member
#10
I got a question. In the HTML I can see that you're writing "community/threads/{option}" but I'm using a route filter for threads called "topics" however the link generated by the BB code doesn't recognize the route filter. A workaround is to replace "threads" with "topics" in the HTML replacement but I'm wondering if there is a way to get it to recognize the route filter automatically?

When using the add-on by @digitalpoint it properly recognizes the route filter.
 

SneakyDave

Well-known member
#11
Could be possible by utilizing a callback, but seems to me that it would be overkill coming up with that just for a "topics" route filter. Unless I misunderstand what you're trying to accomplish.
 

imthebest

Well-known member
#12
I was thinking it was going to be easy. Anyway I have no problem in simply replacing "threads" with "topics" in the HTML replacement field. Thanks :)