Thread Thumbnail by AddonsLab

Thread Thumbnail by AddonsLab [Paid] 2.10.0

No permission to buy ($29.99)

AddonsLab

Well-known member
Thanks buying it now, please send me a message with your paypal info so i can send you some beer money.

Thank you for the purchase and your offer! No need for any additional payment, feel free to check-out our add-ons and purchase some if you find them interesting.

Thank you!
 

cjwinternet

Active member
Purchased, installed and working OK.

We could do with removing the circle shape of the avatar, and increasing the avatar size to something meaningful.

Also, when the lightbox is turned on, it doesn't work for every thread?
 
Last edited:

AddonsLab

Well-known member
Purchased, installed and working OK.

We could do with removing the circle shape of the avatar, and increasing the avatar size to something meaningful.

Also, when the lightbox is turned on, it doesn't work for every thread?

We would avoid implementing any sizing on thumbnail simply because admins want different thumbnail size based on the design of their website. If you have problems increasing the size just post the URL to your website and we will provide some suggestion on how to set the size for your theme.

Lightbox appears only if the thumbnail is set based on an attachment and if the current user has permission to see the lightbox. We will release a version soon that will support lightbox on usual images as well (detected directly from post content).

Thank you!
 

BobbyUgh

Member
Installed on our forum and its working great as intended, only suggestion i could possible give is a option to choose which forums are included, as we would like to exclude a few forums, but for now its great.

Thanks again.
 

AddonsLab

Well-known member
Installed on our forum and its working great as intended, only suggestion i could possible give is a option to choose which forums are included, as we would like to exclude a few forums, but for now its great.

Thanks again.

We will implement the feature soon and release here.

In fact it doesn't make sense at all. All these images are hosted on our CDN...

View attachment 171392

Can you please provide the URL of the page above? Could not find any of threads mentioned in the screenshot to check.

Thank you!
 

BobbyUgh

Member
Small bug when the image in the thread has a long url.

Example URL
Code:
https://scontent.fcgk9-1.fna.fbcdn.net/v/t1.0-9/28577828_2041251452782701_8463727675388772760_n.jpg?_nc_eui2=v1%3AAeHP3hfHi4d_7L8pGc29kcKIi1yCKvNu0XXwfcEu6iViCyvT9EdreJmCrS4wy4HGZLINqI16KHlmXzliAGZoXFk4D2Of0DNq1R1sHYOsEkieQV4nEGusjbwJ5DOiFB-bbVs&oh=2764939db86a049b756e74055f64888f&oe=5B0A64E1

Code:
[LIST]
[*]Template public:altt_thumbnail error: Please enter a value using 255 characters or fewer.
[/LIST]
#0 src/addons/AL/ThreadThumbnail/Service/Editor/ThreadThumbnail.php(80): XF\Mvc\Entity\Entity->save()
#1 src/addons/AL/ThreadThumbnail/Service/Detector.php(65): AL\ThreadThumbnail\Service\Editor\ThreadThumbnail->saveThumbnail(Object(EWR\Porta\Entity\Thread))
#2 src/addons/AL/ThreadThumbnail/XF/Entity/Thread.php(81): AL\ThreadThumbnail\Service\Detector->detectThreadThumbnail(Object(EWR\Porta\Entity\Thread))
#3 src/addons/AL/ThreadThumbnail/XF/Entity/Thread.php(141): AL\ThreadThumbnail\XF\Entity\Thread->_setupThumbnailInfo()
 

BobbyUgh

Member
Small bug when the forum contains a redirected thread

Error: Call to a member function toArray() on null src/addons/AL/ThreadThumbnail/Service/Detector.php:97 #0 src/addons/AL/ThreadThumbnail/Service/Detector.php(48): AL\ThreadThumbnail\Service\Detector->getThreadFirstAttachment(Object(EWR\Porta\Entity\Thread)) #1 src/addons/AL/ThreadThumbnail/XF/Entity/Thread.php(81): AL\ThreadThumbnail\Service\Detector->detectThreadThumbnail(Object(EWR\Porta\Entity\Thread)) #2 src/addons/AL/ThreadThumbnail/XF/Entity/Thread.php(141): AL\ThreadThumbnail\XF\Entity\Thread->_setupThumbnailInfo() #3 [internal function]: AL\ThreadThumbnail\XF\Entity\Thread->hasThumbnail()

Temp Fix:
Code:
    public function detectThreadThumbnail(Thread $thread)
    {
        if ($thread->discussion_type == 'redirect')
        {
            return;
        }
 

AddonsLab

Well-known member
AddonsLab updated Thread Thumbnail by AddonsLab with a new update entry:

Enhanced automatic thumbnail configuration and other improvments

This version enhanced the interface for enabling/disabling automatic thumbnails. Now admins can choose to enable/disable automatic thumbnails board-wide, as well as decide in which forums to enable or disable:

View attachment 171625

Another improvement is lightbox mode for images detected from post text.

The version also fixes several minor bugs reported.

The new version is available for all licensed customers at...

Read the rest of this update entry...
 

AddonsLab

Well-known member
@BobbyUgh , the issues you have reported are now fixed in the latest release. Please check.

@cjwinternet , in the latest version we have updated the layout a bit. Here is a CSS rule that at least for the default theme increases size of avatars for all cases:

CSS:
div[data-type=thread] .structItem-cell.structItem-cell--icon {
    width: 90px;
}

div[data-type=thread] .structItem-iconContainer .threadThumbnailWrapper .avatar {
    width: 74px;
    height: 100px;
}

Please try it out after applying the latest version (1.2.0). Just let us know if you still see any issue and we will try to assist with your custom theme as well.

Thank you!
 

Yawn

Member
Just purchased, really enjoying the simplicity of it so far. I've got two feature requests for you to consider, with that said.

1. If the lightbox option is disabled, link the thumbnail to the thread instead. Currently if we're not using the lightbox option, the thumbnail doesn't do anything when clicked which (imo) is an unexpected behavior for the user.

2. Consider adding an additional option under 'Avatar on corner' for 'Latest Replier's Avatar' or similar. It's up to you if you see the worth of this functionality, I just personally think it may offer more to the user. The thread starter's avatar isn't that useful in my opinion, and this acts as a hybrid since it will automatically show the user's own avatar if they recently applied to the thread.

edit: I'm having these errors on all pages with a submit thread/reply dialogue.
Code:
[Error] Failed to load resource: the server responded with a status of 404 (Not Found) (ThumbnailSelector.js, line 0)
[Error] Did not load script at 'website.com/AL/ThreadThumbnail/ThumbnailSelector.js?_v=8d665926' because non script MIME types are not allowed when 'X-Content-Type: nosniff' is given.
 
Last edited:

AddonsLab

Well-known member
Hello, @Yawn

Thank you for the suggestions, we will consider them both and implement them soon.

Regarding the error, I see the path to the script seems to be wrong in your case, it should be "js/AL/ThreadThumbnail/" and it seems to miss the "js" part. Please make sure you have uploaded the "js" folder you can find in the package to your board. If you keep seeing the error, please post the URL to your forums and we will have a look.

Thank you!
 
Top