Resource icon

[******] Thread tag 1.0

No permission to download

Nudaii

Well-known member
ability to not force tags would be great as some users don't use them

also ability to move the tag field to under the editer box (instead of under subject)
 

Adam Howard

Well-known member
ability to not force tags would be great as some users don't use them

also ability to move the tag field to under the editor box (instead of under subject)
THIS

If anything, at least the option to not be forced would be good.

I do see some value with it on top though. We used vBulletin and IPB before and hardly anyone even knew there was a tag option; if you can seriously believe that. I find most people do not look past the reply button. :eek:

So for the 1st time people are using tags and kind of liking it. But there are those who dislike being forced too.
 

Andy.N

Well-known member
Yes, I remember being the only person to use tags in my VB days.
I think @dinh thanh is going to release his tag addon in the future as well.
 

duydangle

Active member
Yes, I remember being the only person to use tags in my VB days.
I think @dinh thanh is going to release his tag addon in the future as well.
I don't know if Dinh Thanh will release his tagging addon. I see that's a sophisticated plugin, so maybe if released, it will be a paid addon.
 

scarletto

Member
to delete it gives this Error
Server Error
Mysqli statement execute error : Unknown table '******_tag'​
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in ******/Tags/Install.php at line 72
  4. ******_Tags_Install->_uninstallVersion1() in ******/Tags/Install.php at line 66
  5. ******_Tags_Install::Uninstall() in XenForo/DataWriter/AddOn.php at line 193
  6. XenForo_DataWriter_AddOn->_postDelete() in XenForo/DataWriter.php at line 1738
  7. XenForo_DataWriter->delete() in XenForo/ControllerAdmin/AddOn.php at line 116
  8. XenForo_ControllerAdmin_AddOn->actionDelete() in XenForo/FrontController.php at line 310
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  10. XenForo_FrontController->run() in /var/www/html/web1253/html/brainlag-Forum/admin.php at line 13
Same problem. Good thing I installed it on a test forum instead of a live one. :eek: Reverted back to previous v of the DB and will leave uninstalled until some of the bugs mentioned earlier in the thread + this one, not being able to easily/cleanly remove the add-on can be resolved.

Great to see someone working with getting a tag feature going, though. :D One feature that would be nice in addition to removing the requirement that the thread starter must add a tag would be the ability for others to add tags to an existing thread (controlled by usergroup).
 
THIS

If anything, at least the option to not be forced would be good.

I do see some value with it on top though. We used vBulletin and IPB before and hardly anyone even knew there was a tag option; if you can seriously believe that. I find most people do not look past the reply button. :eek:

So for the 1st time people are using tags and kind of liking it. But there are those who dislike being forced too.
I too would like to back the option of not forcing guests to put in tags.

Also, how can I feed my tags onto the navigation panel on the home page? I would love a block with like the top viewed tags in.
 

Donny

Active member
How can we disallow private forums from being tagged? They appear in the tag pages and you can see the thread titles of the private threads and I don't want that type of setup.
 

Digital Doctor

Well-known member
My 1st XenForo modification conflict. Interesting.
Now lets see how quick I can find a resolve (that doesn't require one or the other being removed).
Not so quick it seems.
http://www.sociallyuncensored.eu/forums/tags/sex/

Code:
Template Errors: waindigo_thread_list_item_replace_last_post_avatar
Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /home/sociall1/public_html/forums/library/XenForo/Template/Helper/Core.php, line 1495
Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /home/sociall1/public_html/forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined
 

Adam Howard

Well-known member
Not so quick it seems.
http://www.sociallyuncensored.eu/forums/tags/sex/

Code:
Template Errors: waindigo_thread_list_item_replace_last_post_avatar
Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /home/sociall1/public_html/forums/library/XenForo/Template/Helper/Core.php, line 1495
Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /home/sociall1/public_html/forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined
If you have a solution, I'm willing to hear it.
 

Jon W

Well-known member
Anyone notice this when you actually click 1 of the word in the tag cloud ?

Code:
Template Errors: waindigo_thread_list_item_replace_last_post_avatar
 
    Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1495
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined in /forums/library/XenForo/Template/Helper/Core.php, line 1396
 
Template Errors: waindigo_thread_list_item_last_post_avatar
 
    Argument 1 passed to XenForo_Template_Helper_Core::helperAvatarHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1534
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1562 and defined in forums/library/XenForo/Template/Helper/Core.php, line 1396
    Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1495
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined in /forums/library/XenForo/Template/Helper/Core.php, line 1396
I have modified my add-on to avoid the conflict with this add-on. Note that this is not an admission of guilt for the add-on conflict on my part ;).

Please check out the update:
http://xenforo.com/community/resources/add-user-avatar-to-last-post-by-waindigo.266/
 

Adam Howard

Well-known member
Got it up and running on the site, but noticed a line of Vietnamese is showing up on my pages now. When you click on the tag, it brings up a page with all threads tagged with that key word. However underneath the key word there's a line:



Where do I change this?

http://www.wearepopslags.com/forum/tags/Lady Gaga/
FIX is Attached (scroll down)


I found this 2x

Code:
Các bài viết về
Which means

Code:
Articles on
I also found this 2x

Code:
Tìm kiếm thông qua tag
Which means

Code:
Search by tag
And finally I found

Code:
Có 100 tags sử dụng nhiều nhất.
Which means

Code:
100 most used tags.
Attached is the add-on / plug-in (whichever you prefer to call it) with the correct English wording (spelling).
You should simply be able to overwrite by selecting this file and doing an update on this add-on / plug-in. ;)
 

Attachments

Adam Howard

Well-known member
Recommend everyone to un-install (or de-active).

Noticed my site was running slower and slower and slower. Seems this modification adds 1 database queries PER tag.

When active =
DB Queries 87

After removal / de-active =
DB Queries: 14
 

Adam Howard

Well-known member
Recommend everyone to un-install (or de-active).

Noticed my site was running slower and slower and slower. Seems this modification adds 1 database queries PER tag.

When active =
DB Queries 87

After removal / de-active =
DB Queries: 14
Not 100% sure if this is completely removed or not. I de-activate this first (no issue there), but upon trying to un-install I got the following:

Mysqli statement execute error : Unknown table '******_tag'
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 317
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in ******/Tags/Install.php at line 72
  4. ******_Tags_Install->_uninstallVersion1() in ******/Tags/Install.php at line 66
  5. ******_Tags_Install::Uninstall()
  6. call_user_func() in XenForo/DataWriter/AddOn.php at line 193
  7. XenForo_DataWriter_AddOn->_postDelete() in XenForo/DataWriter.php at line 1738
  8. XenForo_DataWriter->delete() in XenForo/ControllerAdmin/AddOn.php at line 116
  9. XenForo_ControllerAdmin_AddOn->actionDelete() in XenForo/FrontController.php at line 310
  10. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  11. XenForo_FrontController->run() in /*/*/*/forums/admin.php at line 13
 

yavuz

Well-known member
The developer just dumped the thread and went awol. I unistalled all the others, wouldn't recommend since I got a lot of errors and incompatibility issues with other addons.
 

Xyphien

Active member
Question: How do you edit tags in a post without any tags? I tried going to edit, more options, and also editing the post in moderator format. There are no places to edit the tags of posts that have no tags in them.
 
Top