• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

[******] Thread tag 1.0

No permission to download

vinavb

Active member
#1
vinavb submitted a new resource:

[******] Thread tag (version 1.0) - thread,tag

[FEATURES]
1. Create tags for new thread
2. Listing all threads with specified tag.
3. Search by tag (still on develop - update on next version)

[INSTALLATION]
1. Upload files/directories under upload to your XenForo's root
2. Import addon xml
3. Go to AdminCP -> [******] - Tagging Option, edit with your own settings

Please let's me know your feedback and suggestion.


Demo images:
View attachment 28574
Create tag for new thread

View attachment 28575
Tag list below post...
Read more about this resource...
 

DRE

Well-known member
#2
Thanks! Liked and rated. How do I add a tag to an existing thread? It's not showing a tag box when editing the thread.
 

Wulfspider

Active member
#5
A few issues and suggestions... otherwise, you're off to a good start. :)

Issues:
  • Tags do not follow "Tag Maximum Length" and "Tag Minimum Length" as set in options, longer/shorter tags than allowed.
  • Tags do not follow any of the limits for that matter... not even the max tags limit.
  • "add a tag" phrase should be customizable via XenForo's system, not in the .js file. Could apply to the height and colors set in the .js file too.
Suggestions:
  • Allow height of box and max width to be adjustable, and no scrollbar.
  • Allow locations of input boxes to be changed, such as below the description fields, top/bottom of thread, etc.
On a side note, I don't see any tag clouds anywhere nor sidebar. The only place I see anything to do with tagging is when creating a thread. Am I missing something? I haven't really looked too much into it yet though... so perhaps I'll figure it out after a bit more sleep.
 

Attachments

vinavb

Active member
#8
A few issues and suggestions... otherwise, you're off to a good start. :)

Issues:
  • Tags do not follow "Tag Maximum Length" and "Tag Minimum Length" as set in options, longer/shorter tags than allowed.
  • Tags do not follow any of the limits for that matter... not even the max tags limit.
  • "add a tag" phrase should be customizable via XenForo's system, not in the .js file. Could apply to the height and colors set in the .js file too.
Suggestions:
  • Allow height of box and max width to be adjustable, and no scrollbar.
  • Allow locations of input boxes to be changed, such as below the description fields, top/bottom of thread, etc.
On a side note, I don't see any tag clouds anywhere nor sidebar. The only place I see anything to do with tagging is when creating a thread. Am I missing something? I haven't really looked too much into it yet though... so perhaps I'll figure it out after a bit more sleep.

that's weird, I just checked it and still got an error message about minimum length
thread_tag4.png

also with maximum length
thread_tag5.png


but it seem still post a new thread with more than 10 tags ... I just forgot about tag cloud, it will be update next version ...

btw, thanks for your submission :)
 
B

bogus

Guest
#11
Trying to delete it gives this Error
Server Error

Mysqli statement execute error : Unknown table '******_tag'
  1. Zend_Db_Statement_Mysqli->_execute() in Zend/Db/Statement.php at line 297
  2. Zend_Db_Statement->execute() in Zend/Db/Adapter/Abstract.php at line 479
  3. Zend_Db_Adapter_Abstract->query() in ******/Tags/Install.php at line 72
  4. ******_Tags_Install->_uninstallVersion1() in ******/Tags/Install.php at line 66
  5. ******_Tags_Install::Uninstall() in XenForo/DataWriter/AddOn.php at line 193
  6. XenForo_DataWriter_AddOn->_postDelete() in XenForo/DataWriter.php at line 1738
  7. XenForo_DataWriter->delete() in XenForo/ControllerAdmin/AddOn.php at line 116
  8. XenForo_ControllerAdmin_AddOn->actionDelete() in XenForo/FrontController.php at line 310
  9. XenForo_FrontController->dispatch() in XenForo/FrontController.php at line 132
  10. XenForo_FrontController->run() in /var/www/html/web1253/html/brainlag-Forum/admin.php at line 13
 
#16
Thanks for this add-on. I noticed that if i delete the thread, the tags are still considered for that thread and shown in the tag list! when clicked on this tag, it open a blank (without title or author) and locked thread (the one that was deleted, permanently). Please add this to your list of updates.

Thanks,
GMS
 

Adam Howard

Well-known member
#17
Anyone notice this when you actually click 1 of the word in the tag cloud ?

Code:
Template Errors: waindigo_thread_list_item_replace_last_post_avatar
 
    Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1495
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined in /forums/library/XenForo/Template/Helper/Core.php, line 1396
 
Template Errors: waindigo_thread_list_item_last_post_avatar
 
    Argument 1 passed to XenForo_Template_Helper_Core::helperAvatarHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1534
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1562 and defined in forums/library/XenForo/Template/Helper/Core.php, line 1396
    Argument 1 passed to XenForo_Template_Helper_Core::helperUserNameHtml() must be an array, null given in /forums/library/XenForo/Template/Helper/Core.php, line 1495
    Argument 1 passed to XenForo_Template_Helper_Core::getUserHref() must be an array, null given, called in /forums/library/XenForo/Template/Helper/Core.php on line 1507 and defined in /forums/library/XenForo/Template/Helper/Core.php, line 1396
 

Adam Howard

Well-known member
#18
And I have this in the xenforo error logs

Error Info

Code:
ErrorException: Undefined index: thread_id - library/******/Tags/ControllerPublic/Thread.php:5
Generated By: Unknown Account, 35 minutes ago
Stack Trace

Code:
#0 /forums/library/******/Tags/ControllerPublic/Thread.php(5): XenForo_Application::handlePhpError(8, 'Undefined index...', '/forums/...', 5, Array)
#1 /forums/library/XenForo/FrontController.php(310): ******_Tags_ControllerPublic_Thread->actionIndex()
#2 /forums/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#3 /forums/index.php(13): XenForo_FrontController->run()
#4 {main}
Request State
Code:
array(3) {
  ["url"] => string(77) "http://www.sociallyuncensored.eu/forums/threads/i-am-firesbreath.13355/page-2"
  ["_GET"] => array(0) {
  }
  ["_POST"] => array(0) {
  }
}