1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 This action is available via POST only

Discussion in 'Troubleshooting and Problems' started by jauburn, Dec 29, 2013.

  1. jauburn

    jauburn Well-Known Member

    I have a friend in Germany who was not able to register for my xenforo site for some reason (registration kept kicking him back when he clicked Finish), so I registered him manually. Now, however, he tried to log in and tells me this happens:

    First he said:

    This time, when I tried to log in, I received the message "Cookies are required to log in to this site. You will not be able to login until they are accepted."

    As I allow cookies, I really have no clue what the problem is, but I'm close to giving up.

    Then he said:

    I played around with my anti-spam software and browser cookie settings, so it should really work now, but still...when I try to log in, I get the message "This action is available via POST only. Please press the back button and try again."

    Any ideas? Thanks.
     
  2. Liam W

    Liam W Well-Known Member

    It looks like his browser isn't passing the relevant content back to the server when he visits a page or performs an action.

    Has he tried using another browser, and/or disabling his anti-vius/spyware/browser addons?

    Liam
     
  3. Jeremy

    Jeremy XenForo Moderator Staff Member

    If he is getting that error, the browser isn't using POST method to submit the data. Did you happen to test it yourself?
     
  4. jauburn

    jauburn Well-Known Member

    No, i cannot test it. He is in Berlin.
     
  5. jauburn

    jauburn Well-Known Member

    Hmm. I've seen several other threads on this topic now, but I cannot nail down a solution. Where should I look?
     
  6. Liam W

    Liam W Well-Known Member

    Have you asked him to use another browser?

    Is it just him, or are others having the issue as well?

    Liam
     
  7. jauburn

    jauburn Well-Known Member

    Just him that I know of. However, you know how these things are: like roaches. If you see one...
     
  8. I'm currently in Berlin as well. If you think it's a location issue, you can send me example credentials via pm. However, I strongly assume it's an individual problem of your friend's browser settings.
     
    Last edited: Jan 5, 2014
    jauburn likes this.
  9. jauburn

    jauburn Well-Known Member

    Sent you a PM. Thanks for the help. Vielen Dank.
     
  10. As expected it works fine for me. My username is alex-in-berlin in case you want to delete me again.
     
  11. jauburn

    jauburn Well-Known Member

    How odd. Thanks for testing.
     

Share This Page