1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 There are manual rebuild processes that have been stopped before completion.

Discussion in 'XenForo Questions and Support' started by jauburn, May 15, 2014.

  1. jauburn

    jauburn Well-Known Member

    I tried uninstalling this add-on, and the process went on and on, finally ending in a 503. Then, when I log into admincp, I see this:

    There are manual rebuild processes that have been stopped before completion. Click here to complete them.

    I click that, and I get another 503.

    How does one fix this? I presume that the uninstall routine of that add-on does not actually work?
     
  2. Mike

    Mike XenForo Developer Staff Member

    A 503 error is likely coming from your server itself -- it may indicate that PHP is crashing or there's some other timeout. Does it show any text on the rebuild before the 503? (What does the 503 page look like?)
     
  3. jauburn

    jauburn Well-Known Member

    Here was the full text of the 503 page:

    Service Unavailable
    Guru Meditation:
    XID: 475686240
    Varnish cache server
     
  4. jauburn

    jauburn Well-Known Member

    Oh, and there was no text on the rebuild before the 503. Just the usual rebuilding templates.... .... ....
     
  5. Mike

    Mike XenForo Developer Staff Member

    "Rebuilding templates..." is the text I was referring to. :)

    Does it take a long time for the error message to appear? (Or does it appear in about 10 seconds?)
     
  6. jauburn

    jauburn Well-Known Member

    Well, the first time it took a looong time for the message to appear - the first time being when I initially tried to uninstall the plugin.

    But now when I click that "There are manual rebuild processes" link, I get an error message very quickly.
     
  7. Mike

    Mike XenForo Developer Staff Member

    Can you disable the Varnish proxy and access it directly?
     
  8. jauburn

    jauburn Well-Known Member

    I can ask the host to disable varnish, but what would I be accessing directly?
     
  9. Mike

    Mike XenForo Developer Staff Member

    The web server. I'm trying to take out any hidden error message or manipulated response from the variables. If it still errors quickly then, it could indeed be down to PHP crashing, but it's hard to say. I have once seen a non-detected include loop in a template (not detected because it wasn't a loop when it was first edited), so I'm wondering if that is a possibility.

    If you submit a ticket with ACP and FTP login details, I may be able to resolve it. (I probably won't be able to look into it until tomorrow though.)
     
  10. jauburn

    jauburn Well-Known Member

    Super. Rather than potentially mess things up myself, I created the ACP and FTP credentials for you and PM'd you the details.

    I had the web host remove apachebooster, which includes varnish.
     

Share This Page