1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed The text editor size is growing exponentially

Discussion in 'Resolved Bug Reports' started by Floren, Oct 18, 2010.

  1. Floren

    Floren Well-Known Member

    I just finished typing a small reply.
    For each key I press, the editor box height increases by 1 line.
    When I press Enter, it increases by 3 lines.

    It was not doing this yesterday... Everything is fine on my live board, so is not a browser issue.
    Edit: Using Google Chrome 7.0.514
    twhiting9275 likes this.
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Not to be too obvious, but does the problem happen here on xenforo.com? What about in different browsers?

    I have never had this problem here or anywhere else. :confused:
  3. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    Oops, I didn't see this the first time. :oops:

    I would be inclined to do some systematic troubleshooting to isolate the problem. If you can isolate it to the forum itself then I would start looking at custom templates, addons, etc. Or even file customizations / problems.

    I suppose it could be a bug, but I can't reproduce it myself.
  4. Brogan

    Brogan XenForo Moderator Staff Member

    Have you tried a hard refresh? It could be a .js issue.
    There have been some updates rolled out today but I don't know if that included any .js changes.

    Edit: Apparently the editor .js was changed today so that is probably the cause of the problem.
  5. twhiting9275

    twhiting9275 Active Member

    And here I thought I was the only one!

    BTW, this happens on new threads too!
    It looks like it does stop eventually, but it does grow and grow and grow ;)
  6. Anthony Parsons

    Anthony Parsons Well-Known Member

    Hell yer... this is annoying as hell in Chrome.

    Screen shot 2010-10-20 at 7.32.41 AM.png
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Which OS/version of Chrome?

    I'm using Win 7 with Chrome and haven't seen that particular problem.
  8. Trombones13

    Trombones13 Well-Known Member

    I'm seeing it with Chrome 7.0.517.41 beta and Windows 7 (64-bit).
    Strangely, it seems to stop at 47 lines for me. haha
  9. Brogan

    Brogan XenForo Moderator Staff Member

    Definitely a Chrome related bug.

    I've just "upgraded" from 6.0.472.63 to 7.0.517.41 and the problem has started.
  10. Floren

    Floren Well-Known Member

    Is not the browser. It does not do this on my live forums, running Beta1.
  11. Brogan

    Brogan XenForo Moderator Staff Member

    This site has had some updates since Beta 1 so it is most likely related to one of those.

    It is browser specific though.
  12. Mark.B

    Mark.B Well-Known Member

    Certainly happens to me now I have updated to Chrome 7. Doesn't grow forever though, it seems to have a maximum size.
  13. Andy.N

    Andy.N Well-Known Member

    Confirmed on Chrome 8.0.552.5 dev
    It is happening on this site as well.
  14. Anthony Parsons

    Anthony Parsons Well-Known Member

    Same here... only on this one.
  15. Floren

    Floren Well-Known Member

    I see what you mean now... it does not do it with other browsers, on xenforo.com site.
    IMO, Chrome is the only developer friendly browser who stays always on the technology edge and allows developers to update their code properly. Wait a little until other bloated browsers catch up. :)
  16. OperaManiac

    OperaManiac Well-Known Member

    same here. i am on the dev channel edition 8.0.552.5 though. :)
  17. g0rn

    g0rn Well-Known Member

    Same here, latest Chrome 7.0.517.41.
  18. Mike

    Mike XenForo Developer Staff Member

    This is fixed now. Chrome can be finicky with its cache usage, so it may take a little time to go away.

    If you're interested, it looks like Chrome 7 reports the scrollHeight of an iframe document to be the height of the frame, not the content. Chrome 6 doesn't do this, and it doesn't seem like the other browsers do. There appears to be an open bug report about it.

    Unfortunately, the improvements I added to the "elastic" WYSIWYG boxes had to be removed for WebKit because of this.
  19. Brogan

    Brogan XenForo Moderator Staff Member

    Thanks Mike.

    I may consider going back to Firefox then if using Chrome is going to mean less/buggy functionality.
  20. Mike

    Mike XenForo Developer Staff Member

    Oh as a side effect, Chrome doesn't shrink the editor either. Grr...

Share This Page