• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 The server did not respond in time. Please try again.

#1
So this has been happening to me all the time and I can't figure it out myself. Basically, whenever someone tries to reply to a topic or do a reply to a conversation, it gives this error.



Despite of this error, the reply gets posted. It only displays after I refresh the page.
I've tried disabling all the addons I've installed but that doesn't seem to solve the issue.

What could I possibly try to solve this issue?

I'm using XenForo 1.1.3 with XenAtendo, XenPorta, [bd] Tag Me and TaigaChat addons.
There are few outdated templates.
 

Jake Bunce

XenForo moderator
Staff member
#2
That can be the result of a failed or slow SMTP connection (when sending notification emails on reply). A failed SMTP connection will normally show in the log:

Admin CP -> Tools -> Server Error Log

If the log contains mail errors then you need to check your SMTP info:

Admin CP -> Home -> Options -> Email Options

You can also try adding this line to your library/config.php file to disable mail functions:

Code:
$config['enableMail'] = 0;
Does that fix the problem? If so then we know it's a mail problem.
 
#3
That can be the result of a failed or slow SMTP connection (when sending notification emails on reply). A failed SMTP connection will normally show in the log:

Admin CP -> Tools -> Server Error Log

If the log contains mail errors then you need to check your SMTP info:

Admin CP -> Home -> Options -> Email Options

You can also try adding this line to your library/config.php file to disable mail functions:

Code:
$config['enableMail'] = 0;
Does that fix the problem? If so then we know it's a mail problem.
In the Server Error Log I see absolutely nothing related to mail errors.
Despite of that I changed that setting to the config file and it seems to be no longer giving the issues for me.

In the Email settings the Email Transport Method is set to Default and the Default Email Address is my gmail email address.