• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 "The requested page could not be found" after upgrading to Xenforo 2.

#1
Hello,

I upgraded to Xenforo 2 today and I am having an issue getting it work properly.

First off, I am trying to set up Xenforo 2 in a different directory to get it set-up and running as I'd wish before making it live. So, I duplicated my live site into a subfolder called nextgen and then upgraded it. I hit a few snags (mainly to do with add-ons), but I got it updated in the end. Now though, none of the links work on my homepage. ACP works fine, but when ever I click on a thread or post it directs me to the error page stating 'The requested page could not be found'.

I have changed to the default theme, so I don't think it's related to my style.

Regards,
Carl
 
#3
It's possible. I haven't checked the .htaccess file. I did change the basic board info and save it, there I noticed friendly URLs was definitely enabled. I assumed the .htaccess file would have stayed the same as it was before copying it over to the test site.

The website is www.crimecoastforums.com/nextgen

I will try to put a clean .htaccess file in the directory and see if that works.
 

Chris D

XenForo developer
Staff member
#4
This will most likely be your index page route. If you had a different value other than "forums/" in XF1 (perhaps pointing to a portal add-on) for your index page route option then that will be why. You'll need to change it back to "forums/" or another valid route.
 
#5
This will most likely be your index page route. If you had a different value other than "forums/" in XF1 (perhaps pointing to a portal add-on) for your index page route option then that will be why. You'll need to change it back to "forums/" or another valid route.
Index page route in Basic Board Information still reads "forums/".

I don't have a portal as my homepage and Xenforo was installed to root before I duplicated it to a new directory to upgrade the test site to Xenforo 2. Would any of those changes require me to edit the Index page route?
 
#7
Without seeing the site, just a guess - do you have Friendly URLs enabled without an .htaccess file in place?
Check your .htaccess RewriteBase if you moved it to a different directory, that may be set wrong
You two are both spot on!

I need to paste the following into the .htaccess file:
Code:
<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>
Thank you @Brogan, @Chris D and @Jake B. for your help.
 
#9
Hello, I ve got the same problem but couldnt solve it yet... Could anyone help me?
You simply need to paste the following into the .htaccess file inside Xenforo test site root. If there isn't a .htaccess file you would need to copy it from you Xenforo live site root.

Code:
<IfModule mod_rewrite.c>
    RewriteEngine On

    #    If you are having problems with the rewrite rules, remove the "#" from the
    #    line that begins "RewriteBase" below. You will also have to change the path
    #    of the rewrite to reflect the path to your XenForo installation.
    #RewriteBase /xenforo

    #    This line may be needed to enable WebDAV editing with PHP as a CGI.
    #RewriteRule .* - [E=HTTP_AUTHORIZATION:%{HTTP:Authorization}]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -l [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^.*$ - [NC,L]
    RewriteRule ^(data/|js/|styles/|install/|favicon\.ico|crossdomain\.xml|robots\.txt) - [NC,L]
    RewriteRule ^.*$ index.php [NC,L]
</IfModule>