1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

"Templates in this style can not be modified, please try another" -- how do I try another?

Discussion in 'Troubleshooting and Problems' started by anotheralias, Oct 30, 2010.

  1. anotheralias

    anotheralias Well-Known Member

    I don't know why I get all these weird problems but, now I can't edit any of the styles because clicking on templates or style properties or anything else gets me this message:


    Templates in this style can not be modified. Please try another.

    I deleted the style I had just created prior to getting this message in case that was the problem, but that didn't help because you choose templates (or whatever) first, and then you choose the style to edit. So it is apparently impossible for me to choose a different style to edit. And, I can not edit the style that the software recognizes as the current one because I get the above message.

    Anybody know how I can get myself out of this catch-22? Thanks for your time. :)
     
  2. Jamie

    Jamie Well-Known Member

    I have run into this as well. I noticed it when I added a style or a child style, so I am not sure if this is what is causing it, but I got it to work by going into the styles, and then in the list of styles off to the right there are links to the Template and the Style Properties. Clicking these links brought me to the templates or style properties and after I did that once, I could come and go to the templates and styles properties like normal.

    Jamie
     
    anotheralias likes this.
  3. anotheralias

    anotheralias Well-Known Member

    Thank you so much Jamie! That worked!

    (In my case I created a style with no parent and then decided to give it a parent - after that, I got the error. Just for reference purposes.)
     
  4. Mike

    Mike XenForo Developer Staff Member

    That should only happen if you disabled debug mode (and last edited the master style).
     
  5. anotheralias

    anotheralias Well-Known Member

    I wasn't editing the master style, unless there's some way I can do that without knowing I'm doing it. I created a new style with no parent, and then decided to make it the child of an existing style.

    However, I deleted that debug mode line weeks ago - if that's what 'disabling' it means.

    (Hope that helps.)
     
  6. Lawrence

    Lawrence Well-Known Member

    If you mean you deleted this line from your config.php file, then yes, debug more is off: $config['debug'] = true; :)


    You can also just comment it out by placing two forward slashes and a space before that line. This way if you want to re-enter debug mode at a later date, just remove the two forward slashes:

    // $config['debug'] = true;
     
    Trombones13, anotheralias and Peggy like this.
  7. anotheralias

    anotheralias Well-Known Member

    Good to know! Although I have to say, debug mode would be a very last resort. It took weeks for those stupid notices to go away! :D
     

Share This Page