1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.3 Templates creating unexisting tags

Discussion in 'XenForo Questions and Support' started by Felomeno, Mar 23, 2014.

  1. Felomeno

    Felomeno Member

    Hi. I have found that the templates are creating sometimes an "unexisting" <a></a> tag and it causes my style to display incorrectly. The error is just showed to logged in members.

    PHP:
    <ul class="tabs"><a>
        </
    a><li class="active"><a></a><a href="members/">Most Messages</a></li>
        <
    li class=""><a href="members/?type=likes">Most Likes</a></li>
        <
    li class=""><a href="members/?type=points">Most Points</a></li>
        <
    li class=""><a href="members/?type=staff">Staff Members</a></li>
    </
    ul>
    That's the code for /members of my site and it's displaying like this:
    [​IMG]

    Do you have any idea?
    It happens in all our styles, including Default Style.

    Edit: if you check the source code... the extra <a> tag doesn't exist.
     
    Last edited: Mar 24, 2014
  2. dieg0

    dieg0 Active Member

    It happens with every style, even from previous backups.

    Also, if we upload the skin to our test site and do the 1.3 style merge everything works just fine. Same addons, server and xF version.

    We really need some help.

    Edit: creating a new style (Default) the issue remains. File Health Check is OK.

    First thing we tried was disabling every addon. We haven't installed anything new btw. Same setup for months except xF 1.3.
     
    Last edited: Mar 24, 2014
  3. Steve F

    Steve F Well-Known Member

    If it does after creating a new styling it is most likely a Template Modification causing the issue.
     
  4. dieg0

    dieg0 Active Member

    As I said after creating a new style (the default one here at xenforo.com) the issue remains.
     
  5. Mike

    Mike XenForo Developer Staff Member

    That's why @Steve F was saying it's likely a template modification (from an add-on, presumably). Look at the template modification list for a mod to this template (member_notable, I think?). You may need to disable it or contact the author.
     
  6. Felomeno

    Felomeno Member

    Hey Mike. I don't think it's a template modification. We just have 3 of them and I disabled all of them. The issue is still there.
    Also, it's not only on that route. It's also in /personal-details and /alerts and some others.

    This is other weird thing happening:

    I checked the account_wrapper template (the one that is generating some of the tags).
    I added a <span>test</span> and when I check the the forum, it displays test wrapped in the "unexisting" <a> tags:

    <a><span>test</span></a>


    Edit: we also disabled all the addons
     
    Last edited: Mar 24, 2014
  7. Jeremy

    Jeremy XenForo Moderator Staff Member

    Just to update this, as I solved this via tickets. The notice displayed had an unclosed anchor tag, which the browsers attempted to rectify and trickled down to cause the above issue.
     
    dieg0 likes this.

Share This Page