TaigaChat Pro - Realtime chat/shoutbox

TaigaChat Pro - Realtime chat/shoutbox [Paid] 1.4.7

No permission to buy (£25.00)

Arkshine

Active member
Sorry to bother you again with the following, but today I've decided to update to 1.0.5, and again I have trouble with the speed mode. I was using 1.0.4 and was working fine ; and as reminder the problem I had was related to open_file_cache (nginx) ; anyway, this time I've just upgraded and nothing else ( the server config has not been changed, nor addon ), and of course I've cleared all the cache as usual (reboot server, browser) ; but here the result : when you type something, it takes like 5 seconds (seems constants) to "load" the text on the chat, and you notice "load" because this time I see the load animation upper right and the input bar is "disabled". Not sure what to do, any ideas ?

EDIT: well, tried to uninstall and install 1.0.4 ; after some weirds things at start, it seems to work as before... It's most likely a problem with nginx, but I'm using more or less base configuration. Not sure what you add in 1.0.5 to be hated by nginx.
 

melbo

Well-known member
No that won't help (would only block access entirely, breaking speed mode), you would need to adjust robots.txt to stop Google seeing the file

Also noted the bug :)

Luke, what CHMOD should this file be (as designed)? I played around with setting it to 600 and now am not sure what you intended it to be. This could be why my archive logs are not running.
 

Luke F

Well-known member
Sorry to bother you again with the following, but today I've decided to update to 1.0.5, and again I have trouble with the speed mode. I was using 1.0.4 and was working fine ; and as reminder the problem I had was related to open_file_cache (nginx) ; anyway, this time I've just upgraded and nothing else ( the server config has not been changed, nor addon ), and of course I've cleared all the cache as usual (reboot server, browser) ; but here the result : when you type something, it takes like 5 seconds (seems constants) to "load" the text on the chat, and you notice "load" because this time I see the load animation upper right and the input bar is "disabled". Not sure what to do, any ideas ?

EDIT: well, tried to uninstall and install 1.0.4 ; after some weirds things at start, it seems to work as before... It's most likely a problem with nginx, but I'm using more or less base configuration. Not sure what you add in 1.0.5 to be hated by nginx.

I run nginx+php-fpm on both my dev and live servers, not sure why it's suddenly broken for you. Will check if anything relevant has changed

would there be anyway to run 2 instances of this chat? i need a separate specific chat for mods only...

That's not currently possible, sorry

Luke, what CHMOD should this file be (as designed)? I played around with setting it to 600 and now am not sure what you intended it to be. This could be why my archive logs are not running.

Fully writeable, depends on your setup but 666 to be safe. Make sure the entire data/taigachat folder is also writable, as temporary files are created for atomic writes.
 

melbo

Well-known member
Fully writeable, depends on your setup but 666 to be safe. Make sure the entire data/taigachat folder is also writable, as temporary files are created for atomic writes.
Thanks. That's how I was configured.
If I manually run the cron, the archive is built correctly. If I don't run the cron manually, the archives are never built.
 

Luke F

Well-known member
Thanks. That's how I was configured.
If I manually run the cron, the archive is built correctly. If I don't run the cron manually, the archives are never built.

Is there any difference between your account's timezone, your server clock's timezone and the default timezone you've configured for guests?
 

melbo

Well-known member
Yes.
That admin account was set to Los Angelos (Pacific) although the server and the guest default is New York (Eastern)
That's an offset of 3 hours.

I've just changed the timezone for that admin account to match and will see what happens the next time the cron runs tonight.
 

melbo

Well-known member
Is there any difference between your account's timezone, your server clock's timezone and the default timezone you've configured for guests?
Well, the cron to archive still failed even though the account was using the same Time Zone as the server and forum. I even created a new thread and used the new thread ID. The strange thing is that when I run the cron manually, it archives fine.
Archives worked fine prior to upgrade to Pro version.
 

Case

Well-known member
Is it possible to display one of xenForo's notices on the full shoutbox page? Can I target a notice just for this page?

Suggestion: Add the message authors username to this class. <div class="taigachat_messagetext ugc"> eg. <div class="taigachat_messagetext ugc username"> - then you could style particular users messages.
 

intradox

Well-known member
Any idea of when /unban might appear?

Also, any chance for a /rules command which will link the user to the forum rules (specified via admin cp)
 

SneakyDave

Well-known member
I don't know if it's been suggested, and I did try to search through all the pages.

regarding...
Inspired by the architecture behind all good 4chan-style imageboard scripts, this system replaces the extremely server-intensive calls to a PHP script on every refresh with a static HTML file that is rewritten when someone posts a message.

Can that html file name be configurable?

Is this file name supposed to be in the [xF]/data/taigachat directory?

Found my answer:
/data/taigachat/messages.html
/data/taigachat/messagesmini.html

It would be nice to have that file name configurable.

For whatever reason, on my nginx setup, that file isn't created, even though I'm using the "speed mode". The data directory and taigachat directory are the right permissions. Can this add-on be changed to report an error if that file isn't writable? I'll try to dig through and see what the problem is with it.

Never mind, my eyes are just bad. "Speed mode" enabled means to use the file system.

I think it should be said that, using "speed mode", you're just replacing your database requests with file requests. If you have a badly performing file system, you may not see a speed improvement.
 

Luke F

Well-known member
Well, the cron to archive still failed even though the account was using the same Time Zone as the server and forum. I even created a new thread and used the new thread ID. The strange thing is that when I run the cron manually, it archives fine.
Archives worked fine prior to upgrade to Pro version.

Have you perhaps modified the cron entry in some way?

Is the cron running at all, ie does your dark_taigachat table contain significantly more than 1000 rows? (if the cron is working it should be constrained somewhere in the 1000-1500 range)

Failing all that, can you PM me admin cp and ftp details to take a look?

Is it possible to display one of xenForo's notices on the full shoutbox page? Can I target a notice just for this page?

Notices will display as normal on the full shoutbox page out of the box.

To display a notice only on this page, use the following criteria:

clfm.png



Suggestion: Add the message authors username to this class. <div class="taigachat_messagetext ugc"> eg. <div class="taigachat_messagetext ugc username"> - then you could style particular users messages.

user id would be a better thing to use, but this is better done as a template edit on your personal setup, as there's no wide use for it.

Any idea of when /unban might appear?

Also, any chance for a /rules command which will link the user to the forum rules (specified via admin cp)

/unban is in the pipeline

/rules and such are unlikely to happen, I'm sure most people would rather click a link than type a command

I don't know if it's been suggested, and I did try to search through all the pages.

regarding...


Can that html file name be configurable?

Is this file name supposed to be in the [xF]/data/taigachat directory?

Found my answer:
/data/taigachat/messages.html
/data/taigachat/messagesmini.html

It would be nice to have that file name configurable.

For whatever reason, on my nginx setup, that file isn't created, even though I'm using the "speed mode". The data directory and taigachat directory are the right permissions. Can this add-on be changed to report an error if that file isn't writable? I'll try to dig through and see what the problem is with it.

Never mind, my eyes are just bad. "Speed mode" enabled means to use the file system.

I think it should be said that, using "speed mode", you're just replacing your database requests with file requests. If you have a badly performing file system, you may not see a speed improvement.

Configurable file name is quite a good idea actually for security (admittedly by obscurity), will add that.

And it is not just replacing the database, but much more importantly the whole php interpreter, xenforo framework, bbcode parser and several queries taigachat without speed mode takes on every refresh. Also the file is likely to be cached in ram by the os.
 

Luke F

Well-known member
I want it, how many does it cost on dollars? Or i cannot pay with dollars? :(

If you would rather pay in dollars, please send $40 USD via Paypal to
2fuk.png
and I will process it manually.


*Note for anyone else reading this post, this is a one-time offer as obviously conversion rates will fluctuate.
 

Sheldon

Well-known member
Have you perhaps modified the cron entry in some way?

Is the cron running at all, ie does your dark_taigachat table contain significantly more than 1000 rows? (if the cron is working it should be constrained somewhere in the 1000-1500 range)

Failing all that, can you PM me admin cp and ftp details to take a look?

Not sure if this is the same issue or not, but I have noticed if you have a TON of images added into the shoutbox, and for whatever reason, not allow that many to be posted in you regular messages, it will not archive either.

I saw a site (yes, licensed... :p) with say... 7 or 8 youtube videos in the shoutbox, it wouldn't post to archive, because only 5 total media things were allowed in any one message. May be some conflict like that.
 

melbo

Well-known member
Have you perhaps modified the cron entry in some way?

Is the cron running at all, ie does your dark_taigachat table contain significantly more than 1000 rows? (if the cron is working it should be constrained somewhere in the 1000-1500 range)

Failing all that, can you PM me admin cp and ftp details to take a look?
Details sent. I believe the cron is failing altogether since upgrade to Pro.
 

Robyn Unc Privette

Active member
What if you have secret forums and don't want the threads being shown in the shoutbox. I can't do the usergroup id thing to solve it because admins, artist group and moderating group all have access to that forum but also post in the other public forums.
 

Luke F

Well-known member
What if you have secret forums and don't want the threads being shown in the shoutbox. I can't do the usergroup id thing to solve it because admins, artist group and moderating group all have access to that forum but also post in the other public forums.

Create a completely custom set of permissions for a user that allow access to the forums you want displayed
 
Top