1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Tables Went *POOF*

Discussion in 'Server Configuration and Hosting' started by ProCom, Sep 28, 2013.

  1. ProCom

    ProCom Active Member

    NOTE: This isn't so much an issue with xF or this particular plugin as it is a general question about mySQL and phpMyAdmin. Again, since I don't believe this is plugin related I'd like to ask that this thread be left as a general request / troubleshooting thread. Thanks!

    I installed the "Library" addon for xF... it's really very nice and simple for users to create articles.

    I created 10 test articles in the system, exported the four (4) tables in PhpMyAdmin. I wanted to test to see if I could export from my current CMS and import into this one. As a test I manually inserted a few new rows into 2 of the tables and manually entered the data in a way that matched the existing rows.

    I pulled up the library page on xF and it worked perfectly! I thought this would be a great way to import all my pages!

    Well, when I went back to PhpMyAdmin to do some more work in the library tables and two of the four tables were missing!?!?!?

    I did repairs on the tables, and the database. Went into the DB via shell / ssh, and still couldn't find them. I restarted MySQL and that didn't help either.

    Here's the CRAZY part: The library program is still working and the data in the missing tables is still there! It's like they are behind some Romulan cloaking device!!!!

    I even tried completely uninstalling Library and then reinstalling it. All the data was fresh in the program, but still, those two tables were missing.

    Any ideas on what happened how to find these two missing tables?

Share This Page