• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Syntax errors on webpage, says IE 8

jauburn

Well-known member
#1
Getting the yellow exclamation point in the lower left-hand corner of IE when I enter my forum. The little arrow follow me around to every page. Here's the message text from the home page:

Webpage error details
User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729; Media Center PC 6.0; InfoPath.3; .NET4.0C; .NET4.0E)
Timestamp: Thu, 5 Dec 2013 12:41:49 UTC

Message: Syntax error
Line: 26
Char: 1
Code: 0
URI: http://poetrycircle.com/forum/

This is the text when you click the yellow exclamation point and copy error details.

Any idea of how to get rid of this? Thanks.
 

Jeremy

Well-known member
#2
You have a JavaScript include to the main index of your forum it appears. You'll need to find that and remove it.
 

jauburn

Well-known member
#3
You have a JavaScript include to the main index of your forum it appears. You'll need to find that and remove it.
Well, that's going to be a mystery to me, then. I haven't included anything myself. I do have some plugins installed.
 

cclaerhout

Well-known member
#5
It seems you've got an open script tag inside a script tag.
Code:
  <script>
<!-- Google Analytics -->
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-46123108-1', 'poetrycircle.com');
  ga('send', 'pageview');

</script>
Try to delete the <script> above <!-- Google Analytics -->.