1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.5 Super_Administrator and Administrator locked out... *brilliant*

Discussion in 'Installation, Upgrade, and Import Support' started by MetalRush, Feb 6, 2016.

  1. MetalRush

    MetalRush Member

    Just tried to install xenForo on our production site.
    During import of our users, it asked to merge mu user-account and admin account.
    I made up a new name.
    Import went well. Forum was up and running... *Yeeeee*
    Advice by the script: check the (user-)permission.
    So I did.
    I also changed the super_moderator back to my original name.
    Als tried to get the user to become 'super_moderator'. I do not want those rights on my user account...
    Since then: Forum says: ERROR. You have no permissions to view this page.
    This goed for my administrator account (which can not become super_moderator by the love of God) and my personal account (who is still super_moderator).
    So: I now have a forum, which cannot be altered by any admin or moderator... W T F ?!
  2. Brogan

    Brogan XenForo Moderator Staff Member

    It's not clear what the issue is as the thread title suggest one thing and the post content another.

    You should be able to access the ACP directly by navigating to /admin.php.
    That assumes your account has administrator privileges.

    If you are actually locked out then you can perform a password reset.

    If you are having permission related issues then you can use the Permissions Analyzer to determine where the incorrect setting is.
    These guides will help in understanding how permissions work:

    The Help manual explains how Administrators and Moderators function: https://xenforo.com/help/users/
    It is a different concept to other software you may be familiar with.
  3. MetalRush

    MetalRush Member

    The admin-page was also not accesable. Same error message.
    I just solved it via a very peculiar way: I clicked "Back" until I was on the User Group Page (I was there already, a few minutes ago).
    Went to the UserGroup Permissions and choose Administrative, set the rights for the Administrative User Group (you REALLY have to look into the import script from PHPBB3.0.x to xenForo). And set all rights to 'Allow' (accept two step verification)..
    I think that is not really what should have happened. I am happy it did... but security wise, it is not desirable (my 2 cents).
  4. MetalRush

    MetalRush Member

    I still have an issue with the super_moderator.
    How can I change that to another user?
  5. Robust

    Robust Well-Known Member

    I think you did something wrong in your import. I'm still a bit confused with your issue.

    Seems like you were missing some permissions, either inherited from the merge or otherwise removed. Make yourself super admin, then go into the administrators page and tick all of your admin permissions, and then you can modify groups and whatnot.

    Regarding super_moderator - do you want to merge that user with your own, or rename that user so you can rename your admin account to super_moderator?
  6. MetalRush

    MetalRush Member

    That was the whole point, Robust; I had two accounts: one as 'administrative' and one as 'super_administrator.
    I changed the name of the super_moderator (since it asked me to merge it during import).
    I also changed some settings on the Administrators page. Since then my personal account and the super_administrator could not log in. Even not in the admin page.
    I guess this is due to the fact that I did not set the persimmsions for the usergroup 'Administrative'. That is what I changed, after clicking a number of times on my 'Back' -button. The standard persmissions for the usergroup 'Administrative' was set to 'Not set (no)' after the import (not all, but a lot of options).
  7. Brogan

    Brogan XenForo Moderator Staff Member

    Permissions are unrelated to administrator and moderator status, as it explains on the Help page I linked to previously.

    If your account has administrator status then you can log in to the ACP, regardless of user group permissions.

    If you also take the time to read the permissions guide I linked to, you will see that most of the user group permissions should be Not Set (No), as they will be inherited from the Registered user group.
    Robust likes this.
  8. MetalRush

    MetalRush Member

    Thanks for your reply, Brogan.
    To reply in order:
    1) I never mentioned anything about status. What are you refering to?
    2) My experience is different. Both my accounts (one being super_administrator, the other member of the administrative user group) were not able to login anymore.
    With this quotation you assume that everyone is member of the usergroup 'Registered User'.
    After importing my PHPBB database, all my users only have one usergroup. Does that mean I have to check all my users, for their usergroup?
    [offtopic] Is there a way to see (on the admin page) all users in a specific user group? Perhaps I am missing something... but didn't find it yet[/offtopic]
    Last edited: Feb 6, 2016
  9. Robust

    Robust Well-Known Member

    Yeah, press "Search Users" in the left hand panel and you can select criteria to search users.
    MetalRush likes this.
  10. melbo

    melbo Well-Known Member

    During import you could have assigned one of your accounts a different email address which would have preserved both.
    MetalRush likes this.
  11. MetalRush

    MetalRush Member

    I know what you mean. But what I would like is an overview of all users in a specific user group.
    E.g.: I have a group called 'Sponsors'. I would like to know who is member of this group.

    You are perhaps right, because that is what I also did. Funny it took a few minutes before it kicked in. I did change some other settings afterwards.

    Thanks for your replies all. Much appreciated. New xenForo user here.
  12. Robust

    Robust Well-Known Member

    Yeah, put the search params as the group "sponsors" and it'll show all the users
    MetalRush likes this.
  13. MetalRush

    MetalRush Member

    I'm having a difficult day today... Just tried it, after your first reply and it didn't work.
    Now I am doing exactly the same and it works...
    Note to self: Having the flu and upgrading your forum isn't a good combo :sick:

    Thanks, Robust

Share This Page