XF 2.0 Super Admin

thenashy

Active member
I'm having trouble setting a super admin in XF2.

In my config in src/config.php I have the following line;

$config['superAdmins'] = '1976';

This still displays the message that I don't have super admin rights.
 

ozzy47

Well-known member
XF 2.0 doesn't actually use superAdmins in the config anymore. You can set an Admin as a Super Admin via the Admin CP.
 

thenashy

Active member
How do I avoid this when I'm attempting to set it though. This is the page it's directing me to.

You must be a super administrator to access this page. This can be configured in the Administrators section of the Admin CP.
 

ozzy47

Well-known member
The admin with userid 1 will be marked as a super admin. If that user doesn't exist anymore, then you will need to update the xf_admin table directly afaik. I would wait for confirmation from @Chris D or another developer to be completely sure.
 

thenashy

Active member
Userid 1 is there, but it isn't set as admin. I manually set it, and it's not a super admin either.
 

Brogan

XenForo moderator
Staff member
Identify the super admin account and use that to set other admin accounts as super admin.
 

thenashy

Active member
Identify the super admin account and use that to set other admin accounts as super admin.
How? Super Admin should be 1, but it's not, in XF1 it was set as me in the config, now it's not. I appreciate the response, but this isn't actually very helpful.

Would it be best to open a support ticket?

Is this mentioned somewhere in some documentation?
 

ozzy47

Well-known member
I believe you will need to update the xf_admin table directly, but I am unsure of the exact procedure.
 
I think I am starting to realize I am in over my head. I don't see how to liven the page, upload the logo, any of it. I thought this was a standalone program I upload to bluehost on a dedicated page and all the edits were done within the program. Is all of it backend stuff that you need to be a pro to navigate?
 

sbj

Well-known member
I think I am starting to realize I am in over my head. I don't see how to liven the page, upload the logo, any of it. I thought this was a standalone program I upload to bluehost on a dedicated page and all the edits were done within the program. Is all of it backend stuff that you need to be a pro to navigate?
What's your problem? We have dedicated forums for troubles and problems, just open a thread and people will help you.

You need barely touch the backend at all. Just for uploading files (such as for addons) you need to access your server or for example you need to upload a logo. Then on frontend you just need to put the path of the logo and done or just 1-click for installing addons.
 
I was afraid the community would stone basically a dummie to programming. I didn't even know where to find the place on my bluehost cpanel to touch. That's how bad it is. Any step by step you tubes I see are using old versions and it looks different, so have found even that a stumbling block. Can you tell me the first step to get the appearance of the page, and logo up, and then how to liven the url? As of now when I type in the address, it is just a white page. The admin.php does work.
 

sbj

Well-known member
I was afraid the community would stone basically a dummie to programming.
Everyone starts one day from zero. Open a new thread and put your questions in there, this thread is not meant to be for that.
Do you have a domain and which version of Xenforo are you using right now?
 

Brogan

XenForo moderator
Staff member
I have responded to your ticket regarding the server configuration - you need to contact your host and ensure index pages are loaded automatically.

Or, you can try editing the XF .htaccess file in the domain root and adding DirectoryIndex index.php.
Again your host can help with that.

As explained above, to change the logo you need to upload an image file to the server then update the style properties.
You can use the File Manager application in your hosting cPanel to upload the file.
 
Everyone starts one day from zero. Open a new thread and put your questions in there, this thread is not meant to be for that.
Do you have a domain and which version of Xenforo are you using right now?
Thanks for the confidence building post! I will start a new thread with the questions as they come up, and will have bluehost check that index pages are loaded automatically. You guys are super.
 
  • Like
Reactions: sbj
Top