1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Super admin issue

Discussion in 'Troubleshooting and Problems' started by Rho Delta, Dec 15, 2011.

  1. Rho Delta

    Rho Delta Well-Known Member

    in my config.php file I have superadmins set up as:

    $config['superAdmins'] = '1';
    $config['superAdmins'] = '2';

    My username is http://thepetboard.com/members/mike.1/

    I can access the admin panel but cannot preform superadmin functions like seeing the rotating ads link under appearance and clicking on the administrators usergroup.

    Help please!
    Digital Doctor likes this.
  2. Brogan

    Brogan XenForo Moderator Staff Member

    Digital Doctor likes this.
  3. 3c

    3c Active Member

    sorry to bring up an old thread....but I have dived off into the deep end of the permissions pool. I "think" I have it mostly down pat....(famous last words)

    but the super admin...how did the first one come about? Is that automatically whoever installed the software and started setting it up...the first member as it were? Or did I miss something else some where along the way?

  4. Brogan

    Brogan XenForo Moderator Staff Member

    The initial super admin is created when you install the software, using the details you provide.
  5. 3c

    3c Active Member

    Ok, that's what I was thinking....

    yea, these permissions are....something...I'm not sure I've had Jake's 'ah ha' moment yet, but I think I'm going to get stumbled through it anyway...

    Thanks Brogan..
  6. Maarten23

    Maarten23 Member

    Hey Guys,

    I'm currently trying to add a third super admin, as described above. However when I do so my whole ACP just goes blank, I get no errors or anything but I just a blank screen. To resolve this I have to put back the previous config.php.

    Anyone got a clue where this is going wrong?
  7. Brogan

    Brogan XenForo Moderator Staff Member

    I suspect you either edited the config.php file incorrectly or it was saved in an incorrect format (should be UTF-8 without BOM).
    Steve F likes this.
  8. Maarten23

    Maarten23 Member

    Used a different editor and apparently that made the difference. Thnx!
  9. Brogan

    Brogan XenForo Moderator Staff Member

    I recommend Notepad++ for basic file editing.

Share This Page