• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Super Admin, can't create new threads

#1
Hi,

I'm the owner of my site Forge Haven. I'm trying to post a new article and my "Announcements" forum, but in the bottom right corner it says I "don't have privileges to post here". I did recently make it so that only admins can post new threads in this forum, could this be the issue? I'm also in another user group for my rank that is called "Silver Grade 3". The permissions for this forum and user group were setup so that this user group cannot post new threads in this forum. I thought this was the issue, however, I switched it to allowed and I still can't post a new thread. Any ideas?
 
#4
Use the analyze permissions function for the user/node to determine where the and how the final permission is being set.

This guide explains how to set them up: http://xenforo.com/community/resources/implementing-permissions-across-multiple-user-groups.358/
I'm reading over this and have already seen two things that concern me.

1. I'm not in registered group. I will be re-adding myself along with anyone who isn't in it either.
2. The permission for Silver Grade 3 (along with all other ranks) to post new threads in my announcements forum was set to Never. It states that it cannot be overridden, but this is just while it's selected correct? Now that I've switched it to allowed it will no longer be "never", right?
 

snoopy5

Well-known member
#7
Hi,

I have the same problem. I can not post or create a new thread as super admin in a specific announcement forum. XF1.5.10.

i tried already every kind of user and usergroup settings. Also the setting for that specific forum. When I analyse the rights of that super admin, he is allowed to do everything. No restrictions. Always "yes".

i tried it with some regular users. They are only "registered". They can not post neither in the announcement section. Like the super admin, they can post in every other section. It seems like there would be something wrong in the sql db for this forum which can not be deleted via ACP...

what could be the reason for this?
 

snoopy5

Well-known member
#15
Yessssssssssssssssssssssssssssssss!

That was the reason! Thank you very much !!!!!

But in my view, this should then also appear in the analyser option within ACP, because as a matter of fact, the admin can not post theer and in the analyser it shows still "yes" insetad of "no" and then an explanation to it. So this should be fixed for the next version.