• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 2.0 Style question regarding buttons

jadmperry

Well-known member
#1
Anyone know how or where I can change the style elements to get these buttons to show up visibly?

I have tried all of the "button" properties, to no avail.

Thanks in advance!

Jason
1510059424949.png
 

jadmperry

Well-known member
#3
Try

CSS:
.button.button--link
{background:red;
color:yellow;}
I saw that on the "inspect" when I looked at in the browser....but, where do I find that?
Which style property or css file? I searched within ACP for all this (css and button.button--link ) but no results returned.
I know I may be somewhat dense, so appreciate the help!
 

Mr Lucky

Well-known member
#4
I saw that on the "inspect" when I looked at in the browser....but, where do I find that?
Which style property or css file? I searched within ACP for all this (css and button.button--link ) but no results returned.
I know I may be somewhat dense, so appreciate the help!
You don't need to find the css template, best things is to add that code to the style's extra.less template, which should then over-ride the default.
 

jadmperry

Well-known member
#8
This should cover both sets of buttons

.button.button--link, a.button.button--link
And that worked a charm!! Thanks!

Solved my problem, so I really appreciate the help.

Next question, is that a "workaround solution"? That is, is there a better way or "cleaner way" to get that same result? I am not looking a gift horse in the mouth, just curious if I am doing something dumb or inartful in the style. Obviously, it is no longer a pressing issue as your help solved my immediate problem. Just wondering if there is a better method to achieve this.


Either way, really appreciate your help and input @Mr Lucky !!
 

jadmperry

Well-known member
#9
Damnit....

If these were school exams, I think I would get a D+ at best.

I keep coming across this same issue. Here is my latest in Resources Add on:

1510064333998.png 1510064333998.png
 

Steve F

Well-known member
#10
You really should not need to define all that, properties should of worked.

What is the background set for on the button primary property?
 

Mr Lucky

Well-known member
#12
I agree this should not happen and fixing it like this, class by class is not the way to go. You need to find out the rot of the issue.

Somehow in some style property dark link text is now light.

When changing the basic color palette, you should always check that the colours you change to are similar kind of lightness/darkness - whatever the actual hue. (unless you are creating a dark theme in which extreme light becomes extremely dark and vice versa)
 

Steve F

Well-known member
#14
Your accent colors should be part of the main scheme of your style or close to it. Whether you wanted white buttons I’m not sure but I’m guessing not, adjusting the accent color would likely fix most of your issues as the default button link “color” uses a contrast function from the accent color.