1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 strpos() expects parameter 1 to be string

Discussion in 'Troubleshooting and Problems' started by bukoo, Aug 14, 2014.

  1. bukoo

    bukoo New Member

    ErrorException: strpos() expects parameter 1 to be string, array given - library/Zend/Http/Client.php:1040


    #0 [internal function]: XenForo_Application::handlePhpError(2, 'strpos() expect...', '/home/nginx/dom...', 1040, Array)
    #1 /home/nginx/domains/bodyforumtr.com/public/library/Zend/Http/Client.php(1040): strpos(Array, '?')
    #2 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/Helper/Url.php(15): Zend_Http_Client->request()
    #3 /home/nginx/domains/bodyforumtr.com/public/library/AVForums/AutoLinkTitles/BbCode/Formatter/BbCode/AutoLink.php(38): XenForo_Helper_Url::getTitle('http://www.body...', 'http://www.body...')
    #4 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/BbCode/AutoLink.php(103): AVForums_AutoLinkTitles_BbCode_Formatter_BbCode_AutoLink->_autoLinkUrl('http://www.body...')
    #5 [internal function]: XenForo_BbCode_Formatter_BbCode_AutoLink->autoLinkTag(Array, Array, Object(AVForums_AutoLinkTitles_BbCode_Formatter_BbCode_AutoLink))
    #6 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(664): call_user_func(Array, Array, Array, Object(AVForums_AutoLinkTitles_BbCode_Formatter_BbCode_AutoLink))
    #7 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(575): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
    #8 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(488): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
    #9 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(469): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
    #10 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/BbCode/AutoLink.php(107): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
    #11 [internal function]: XenForo_BbCode_Formatter_BbCode_AutoLink->autoLinkTag(Array, Array, Object(AVForums_AutoLinkTitles_BbCode_Formatter_BbCode_AutoLink))
    #12 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(664): call_user_func(Array, Array, Array, Object(AVForums_AutoLinkTitles_BbCode_Formatter_BbCode_AutoLink))
    #13 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(575): XenForo_BbCode_Formatter_Base->renderValidTag(Array, Array, Array)
    #14 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(488): XenForo_BbCode_Formatter_Base->renderTag(Array, Array, 0)
    #15 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(469): XenForo_BbCode_Formatter_Base->renderTreeElement(Array, Array, 0)
    #16 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/Base.php(449): XenForo_BbCode_Formatter_Base->renderSubTree(Array, Array)
    #17 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Formatter/BbCode/AutoLink.php(55): XenForo_BbCode_Formatter_Base->renderTree(Array, Array)
    #18 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/BbCode/Parser.php(505): XenForo_BbCode_Formatter_BbCode_AutoLink->renderTree(Array, Array)
    #19 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/ViewPublic/Forum/View.php(56): XenForo_BbCode_Parser->render('Daha \xC3\xB6nce '...')
    #20 /home/nginx/domains/bodyforumtr.com/public/library/ModEss/ViewPublic/Forum/View.php(25): XenForo_ViewPublic_Forum_View->renderRss()
    #21 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/ViewRenderer/Abstract.php(227): ModEss_ViewPublic_Forum_View->renderRss()
    #22 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/ViewRenderer/Rss.php(31): XenForo_ViewRenderer_Abstract->renderViewObject('XenForo_ViewPub...', 'Rss', Array, 'forum_view')
    #23 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(572): XenForo_ViewRenderer_Rss->renderView('XenForo_ViewPub...', Array, 'forum_view', NULL)
    #24 /home/nginx/domains/bodyforumtr.com/public/library/XenForo/FrontController.php(158): XenForo_FrontController->renderView(Object(XenForo_ControllerResponse_View), Object(XenForo_ViewRenderer_Rss), Array)
    #25 /home/nginx/domains/bodyforumtr.com/public/index.php(13): XenForo_FrontController->run()
    #26 {main}

    array(3) {
    ["url"] => string(62) "http://www.bodyforumtr.com/forums/yemek-tarifleri.25/index.rss"
    ["_GET"] => array(1) {
    ["/forums/yemek-tarifleri_25/index_rss"] => string(0) ""
    }
    ["_POST"] => array(0) {
    }
    }
     
  2. Brogan

    Brogan XenForo Moderator Staff Member

    That appears to be an error related to the AutoLinkTitles add-on.

    Try disabling it and post in the add-on thread for support.
     
  3. bukoo

    bukoo New Member

    Great! Problem solved :)
    Thank you Brogan.
     

Share This Page