• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Strange message in error log


I get this message in the Server Error logs about 20 times a day:

Zend_Http_Client_Adapter_Exception: Unable to Connect to tcp://www.gravatar.com:80. Error #0: php_network_getaddresses: getaddrinfo failed: Temporary failure in name resolution - library/Zend/Http/Client/Adapter/Socket.php:235

Stack Trace
#0 /home/mysite/public_html/library/Zend/Http/Client.php(973): Zend_Http_Client_Adapter_Socket->connect('www.gravatar.co...', 80, false)
#1 /home/mysite/public_html/library/XenForo/Model/Avatar.php(457): Zend_Http_Client->request('HEAD')
#2 /home/mysite/public_html/library/XenForo/ControllerPublic/Register.php(199): XenForo_Model_Avatar::gravatarExists('fw.er5.46s.df@g...')
#3 /home/mysite/public_html/library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Register->actionRegister()
#4 /home/mysite/public_html/library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#5 /home/mysite/public_html/index.php(13): XenForo_FrontController->run()
#6 {main}
Request State
array(3) {
["url"] => string(39) "http://www.mysite.com/register/register"
["_GET"] => array(0) {
["_POST"] => array(13) {
["username"] => string(13) "broolasebrasy"
["email"] => string(23) "fw.er5.46s.df@gmail.com"
["password"] => string(10) "zgr797ZcfG"
["password_confirm"] => string(10) "zgr797ZcfG"
["dob_month"] => string(1) "8"
["dob_day"] => string(2) "19"
["dob_year"] => string(4) "1984"
["gender"] => string(4) "male"
["timezone"] => string(16) "Asia/Vladivostok"
["hash"] => string(0) ""
["agree"] => string(1) "1"
["submit"] => string(6) "G? med"
["_xfToken"] => string(0) ""

The array looks different all the time. Seems like some spammers.. but why are they in that case showing in the error logs? I use KeyCaptcha to keep the spammers away.

Why are I getting these server error logs and could I stop it some way?

Jake Bunce

XenForo moderator
Staff member
The gravatar connection is failing. That's an optional service for user avatars. It's an issue with their service. Probably ignore it. Not much you can do.