1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Partial Fix Strange issues when pasting into rich text editor (holding paste keys)

Discussion in 'Resolved Bug Reports' started by jOOc, Dec 5, 2014.

  1. jOOc

    jOOc Active Member

    When holding down CTRL+V to paste makes the rich text editor behave strange. I have only tested it on Win 8.1 in Chrome 39, IE11 and Opera 26.

    Empty lines disappear, the position in the editor changes and the page position sometimes moves.

    Someone else have seen this issue? Maybe not many people that uses this and not that often, but still annoying.
  2. Mike

    Mike XenForo Developer Staff Member

    I just tried this with whatever was in my clipboard (just a URL) in Chrome and had no issues. I did have some issues in IE and I know roughly why (how the pasting system works). I'll move this to bugs though I'm unsure if there's much we can do. If you simply tap ctrl+v instead of holding it down that should prevent the issue.
    jOOc likes this.
  3. jOOc

    jOOc Active Member

    Thank you, not a big issue but maybe something you can look at when you have the time.
  4. Mike

    Mike XenForo Developer Staff Member

    I'm going to call this a partial fix as I've worked around it as much as I think we can. We now temporarily disable pasting when the paste is still being processed and that seems to help. With really complicated pastes, it may still be possible to trigger this (depends on the browser).
    jOOc likes this.

Share This Page