1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Fixed StopForumSpam: recent duplicate entry

Discussion in 'Resolved Bug Reports' started by Chris D, Nov 2, 2013.

  1. Chris D

    Chris D XenForo Developer Staff Member

    Not often, but sometimes this is appearing in AVForums.com Server Error Log:
    Server Error Log
    Error Info
    XenForo_Exception: Error reporting to StopForumSpam: recent duplicate entry - library/XenForo/Model/SpamPrevention.php:177
    Generated By: LV426, Today at 8:12 AM
    Stack Trace
    #0 /home/sites/avforums/public_html/library/XenForo/Model/SpamCleaner.php(46): XenForo_Model_SpamPrevention->submitSpamUserData(Array)
    #1 /home/sites/avforums/public_html/library/XenForo/ControllerPublic/SpamCleaner.php(53): XenForo_Model_SpamCleaner->cleanUp(Array, Array, Array, NULL)
    #2 /home/sites/avforums/public_html/library/XenForo/FrontController.php(337): XenForo_ControllerPublic_SpamCleaner->actionIndex()
    #3 /home/sites/avforums/public_html/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
    #4 /home/sites/avforums/public_html/index.php(13): XenForo_FrontController->run()
    #5 {main}
    Request State
    array(3) {
      ["url"] => string(57) "http://www.avforums.com/spam-cleaner/priya-kapoor.667177/"
      ["_GET"] => array(0) {
      ["_POST"] => array(12) {
        ["delete_messages"] => string(1) "1"
        ["delete_conversations"] => string(1) "1"
        ["ban_user"] => string(1) "1"
        ["check_ips"] => string(1) "1"
        ["email_user"] => string(1) "1"
        ["email"] => string(152) "priya kapoor,
    Your spam has been removed from AVForums. If you believe this was not correct, please reply or use the contact form:
        ["noredirect"] => string(1) "0"
        ["_xfToken"] => string(8) "********"
        ["_xfConfirm"] => string(1) "1"
        ["_xfRequestUri"] => string(59) "/threads/hmv-10-instore-discount-printable-voucher.1826340/"
        ["_xfNoRedirect"] => string(1) "1"
        ["_xfResponseType"] => string(4) "json"
    Obviously the error is being thrown by SFS, so could be a Service Issue, but in case there's anything that can be done to prevent duplicate entries being sent...
  2. Mike

    Mike XenForo Developer Staff Member

    Unfortunately, there's not much documentation as to the SFS error messages (that I've found). This appears to be a race condition (from the spam cleaner). We did have this error reported once before (but it's not something we've run into here). I'm now suppressing logging of this particular error.

    Note that this is just logged; it doesn't actually show to the person doing the spam cleaning.
    Chris D likes this.
  3. Chris D

    Chris D XenForo Developer Staff Member

    Good enough for me. I thought that would be the case.

Share This Page