• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Statcounter & Xenforo Member IP both different


Well-known member
This is the strange problem i am having. I am not sure why this would happen.

I use Statcounter to monitor traffic on my website. I have someone register to my forum and i can see all of his computer information with statcounter, i can see where he has gone and which threads he visits,
Normal statcounter activity.

In statcounter it says he is from: Russia with a russian IP

But when i go into the admin panel to check the IP of the username he registered with. It does not show his Russian IP. It has an American IP.

So my question is:

Why would Statcounter say he's in russia with a russian ip, but xenforo logs a completely different ip and country,

shouldn't xenforo also log the ip as the same as statcounter?

who is the problem here, xenforo or statcounter




XenForo developer
Staff member
What ISP does the American IP resolve to? If you have a reverse proxy in front of your server and you haven't configured XF to handle it, XF will see the reverse proxy. Similarly, it's possible the user is browsing behind a proxy, but we use the IP of the system connecting as that cannot be spoofed (unlike the reported source IP behind a proxy).


Well-known member
The american ISP says "Cloudflare" I do have cloudflare installed from months ago.

ahh what does this mean? Does it mean it's because of cloudflare?

Does this mean i have to do some technicial things?

oh no!! where can i read about this


Well-known member
it worked!! i just registered a test account and it shows my real ip address

now i can fight this pesky russian person, i will be ready when hes comes back!!

tank you sir!!