Resource icon

Standard Library by Xon 1.12.2

No permission to download

Mr. Jinx

Well-known member
Nice, I was using this library for one of my add-ons. Sometimes it could give file check warnings if another add-on was installed with a new version of this library.
Hopefully by using this add-on as a requirement, we don't have that problem any more. Thanks!
 
  • Like
Reactions: Xon

Xon

Well-known member
I'm open to pull requests for additional helper bits. I've got some very small plans for stuff which integrates into XF but my goal is to have something which isn't active unless directly called.
 

Xon

Well-known member
Yes. the plan is that any add-on which makes database schema changes or complex SQL changes will depend on this add-on.

A couple of my add-on's updating to support XF2.2 will require it so they can support XF2.1 and XF2.2 at the same time
 

Robert9

Well-known member
I have uploaded like normal, but there is no new addon to install.
But i cant update Warning Improvements now.
 

Robert9

Well-known member
I got it. The addon was installed before. But i cant update with that version;
thats why i thought it is not installed.

Warning Improvements requires Standard Library by Xon v1.0.0+
 

Xon

Well-known member
For the end user, very little.

For me? Hopefully less support tickets complaining about checksum errors and not uploading all the files in the zip. It also gives me a sane way to version the contents of this add-on.

It also allows me to invite collaborators to work on shared code without it being a nightmare to redistribute.
 

Xon

Well-known member
Xon updated Standard Library by Xon with a new update entry:

1.1.0 - Feature update, breaking change with some older add-ons

  • Add "replacevalue" templete filter used in a number of add-ons for implementing multi-select filter support
  • Add php 7 type hinting to various methods. Warning: this is a breaking change which cause site-disabling errors with older versions of the following add-ons;

Read the rest of this update entry...
 

rdn

Well-known member
I just updated several minutes ago to version 1.1.0 and it caused my site wide an error and 400+ pages of error logged.
Not sure if I will attempt to update again to 1.1.1 :-(
 

Xon

Well-known member
v1.1.1 fixes the bug, this bug is masked if you have some of my other add-on's installed so I didn't notice it in testing :(

Thankfully only a handful people grabbed the broken release. I've removed that version from XFRM to avoid anyone else grabbing it by mistake
 

rdn

Well-known member
So I'm not affected by this?
Additional 3rd party add-ons may have conflicts, and they will require updating or rolling back this add-on. This add-on is a drop-in replacement after updating the namespace being imported
 

rdn

Well-known member
Addon installed from you:
  • Crowd Moderation 2.0.1
  • Live Content 1.2.0
  • Prefix Essentials 2.0.6 (maybe)
Think I will install the 1.0.0 for now.
 
Top