1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 ssl problem

Discussion in 'XenForo Questions and Support' started by fernando1027, Oct 13, 2014.

  1. fernando1027

    fernando1027 Member

    need to redirect the domain to https but i do not known where in htaccess to change it and its saids not secure because i got images
     
  2. Liam W

    Liam W Well-Known Member

    If your forum index.php is in public_html, then add this to the top of the .htaccess file in the public_html directory:

    Code:
    RewriteEngine On
    
    RewriteCond %{HTTPS} !=on
    RewriteRule ^ https://%{HTTP_HOST}%{REQUEST_URI} [L,R=301]
    You can get around the non-secure error by enabling the image proxy.

    Liam
     
    Last edited: Oct 13, 2014
    MichaelCS likes this.
  3. fernando1027

    fernando1027 Member

    i did but i still have the same problem
     
  4. Liam W

    Liam W Well-Known Member

    Then either you haven't enabled it, or there are other sources of non-ssl material, such as adverts or externally hosted logos.
     
  5. fernando1027

    fernando1027 Member

    i just open the smiles and the error comes out if i do not open them its all good i do not know why
     
  6. Tracy Perry

    Tracy Perry Well-Known Member

    Did you update the URL in the ACP to reflect https after you made the change?
     
  7. fernando1027

    fernando1027 Member

    yeah but now the chat gives mi problems every time a open up smilies or send one get the same error http://prntscr.com/4vwhvs
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    What chat program is it? If one of the external scripts, then you will need to make sure that wherever you are connecting to supports https also.
     
  9. fernando1027

    fernando1027 Member

    taigachat, how would i do that
     
  10. Tracy Perry

    Tracy Perry Well-Known Member

    If TaigaChat, it should respect the URL settings from the ACP... at least mine does on my Apple forum.
     
  11. melbo

    melbo Well-Known Member

    Some of your smilies must be linked from external sites which are http. Same thing happened to me until I found them and moved them to my site.
     

Share This Page