XF 1.5 SSL Error with mails

#0 [internal function]: XenForo_Application::handlePhpError(2, 'stream_socket_e...', '/var/www/html/a...', 206, Array)
#1 /var/www/html/alvaeron.com/www/library/Zend/Mail/Protocol/Smtp.php(206): stream_socket_enable_crypto(Resource id #4, true, 9)
#2 /var/www/html/alvaeron.com/www/library/Zend/Mail/Transport/Smtp.php(200): Zend_Mail_Protocol_Smtp->helo('localhost')
#3 /var/www/html/alvaeron.com/www/library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#4 /var/www/html/alvaeron.com/www/library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#5 /var/www/html/alvaeron.com/www/library/XenForo/Deferred/UserEmail.php(168): Zend_Mail->send(Object(Zend_Mail_Transport_Smtp))
#6 /var/www/html/alvaeron.com/www/library/XenForo/Deferred/UserEmail.php(62): XenForo_Deferred_UserEmail->_sendEmail(Array, Array, Object(Zend_Mail_Transport_Smtp))
#7 /var/www/html/alvaeron.com/www/library/XenForo/ControllerAdmin/User.php(1194): XenForo_Deferred_UserEmail->execute(Array, Array, 10, NULL)
#8 /var/www/html/alvaeron.com/www/library/XenForo/FrontController.php(347): XenForo_ControllerAdmin_User->actionEmailSend()
#9 /var/www/html/alvaeron.com/www/library/XenForo/FrontController.php(134): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#10 /var/www/html/alvaeron.com/www/admin.php(13): XenForo_FrontController->run()
#11 {main}

ErrorException: Email to example@example.com failed: stream_socket_enable_crypto(): SSL operation failed with code 1. OpenSSL Error messages: error:14090086:SSL routines:ssl3_get_server_certificate:certificate verify failed - library/Zend/Mail/Protocol/Smtp.php:20

xenforo keeps throwing these errors, while the ssl cert is a verified wildcard certificate, it's properly installed to postfix and other programs don't complain but as we look at it the setting for mail host used to be "localhost" so I tried setting it to the domainname the certs are for, but as we look at the error xenforo still sends an HELO to localhost, how do i fix this?
It's not sending a HELO to localhost. That's what it's reporting the local server as. That part should be unrelated to your error, as it's the SMTP client throwing the error.

Is this a self signed certificate, or is it signed by an authority (that would be trusted by your OS/OpenSSL)? If it's the former, that's the issue. If it's the latter, it sounds like you may not have the correct openssl.cafile/openssl.capath specified in your php.ini (see here for the changes: http://php.net/manual/en/migration56.openssl.php; here for a resolution example in OS X whose approach may not be the same as for you: https://akrabat.com/ssl-certificate-verification-on-php-5-6/)
Top Bottom