• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

splash page

masterchief

Well-known member
#1
I am interested in setting up a splash page via index.php and then have XenForo activated via splash page. How can this be done. My install is in the ROOT.
 

Brogan

XenForo moderator
Staff member
#2
You can't have two files named index.php in the same directory/root.
It would have to be something like home.php.

Additionally, I believe someone else had problems trying to get this to work as the forum index was being loaded by default.

I'll see if I can find the thread.

Edit: Here's the thread, not the same but it discusses the same issue: http://xenforo.com/community/threads/installing-xenforo-in-root-dir-question.12643/
 

masterchief

Well-known member
#3
I was thinking index.php could be renamed to home.php

splash page would be new index.php

OR

does it have to be that splash page is named home.php????
 

masterchief

Well-known member
#5
I Just read that in the FAQ.... thank you.

So.. How do I change home.php to become startup file for my site??

I can then have index.php asigned to link....
 

masterchief

Well-known member
#7
works great! I am gonna play around with this on my test install and then provide update. thank you again.

UPDATE: I now have home.php loading up... when I click on link to index.php, the home.php reloads itself
 

masterchief

Well-known member
#9
UPDATE: I now have home.php loading up... when I click on link to index.php, the home.php reloads itself.

As I am testing this on WAMP, probably need to work it out on my live site.
 

masterchief

Well-known member
#11
XenForo is adhering to setting in the htaccess, it is never getting to the index.php

going to website from inside the ACP takes me to the home.php page
 

bambua

Well-known member
#12
One way you could get around this would be to have xenforo in a sub directory instead of your website root. That way both directories can have index.php your splash page just clicks through to /whateverfolder/index.php
 

Brogan

XenForo moderator
Staff member
#16
Try changing DirectoryIndex home.php to DirectoryIndex home.php index.php

I did say that there are problems with getting this to work.
Having multiple index files in the same directory is always a challenge to get working properly.
 

bambua

Well-known member
#18
that does not make any sense to me... it is stated in FAQ that index.php filename cannot be changed. Obviously programming logic of XenForo relies upon existence of index.php and its contents in order to function properly. But on the other hand the htaccess can be used to totally disable the system with a DirectoryIndex setting. They are two separate entities and htaccess should not be affecting XenForo like that. This is somewhat limiting is it not?

OK, purged my system, did not mean to offend.
I don't think anyone was offended. Even being 2 seperate entities, when your webserver sees the the .htaaccess file it intercepts the call and forwards it, XenForo isn't doing that. A splash screen option within XF would be nice but we always have other options :D