1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

special chars on title

Discussion in 'Troubleshooting and Problems' started by OlijO, Nov 5, 2010.

  1. OlijO

    OlijO Member

    Hello,

    For some reason my xenforo installation doesnt allow special chars (such as àèìò) on the title when creating a new thread.

    Does anyone know why is this? There is nothing on webserver logs nor on the error log table from xenforo. I only get a "A server error occurred. Please try again later." when I hit on create thread button so Im not even able to get the thread created. This chars are allowed if they are typed on the thread body.

    It doesnt look like a server side related problem so Im here to see if you guys could help on finding whats the real reason.

    Thanks in advance.
     
  2. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    I don't have this problem on my forum.

    Check the error log for specific errors:

    Admin CP -> Tools -> Server Error Log

    Or enable debug mode by adding this line to your library/config.php file:

    Code:
    $config['debug'] = 1;
    
    Then reproduce the error again. It should show a more detailed error message. Please post that error here.
     
  3. OlijO

    OlijO Member

    Hello,

    Thank you for the help. As stated above, there is nothing on the error log table (server error log) when trying this.
    If I enable debug mode, when I hit create thread nothing happens and the windows that appears showing the error doesnt show up anymore.

    Please advice.
     
  4. OlijO

    OlijO Member

    Heres a screenshot with debug mode enabled. (Notice the X mark and the window not showing up)
     

    Attached Files:

  5. Jake Bunce

    Jake Bunce XenForo Moderator Staff Member

    That's odd.

    Without a detailed error message or the ability to reproduce the problem this is difficult to work with.

    I see you are running a custom style. It doesn't hurt to try the default style.

    Admin CP -> Appearance -> Styles -> Create New Style

    Create a new style with no parent. Then click the radio bubble on the following page to set that style to default. Now try to reproduce the problem again with the new style active.

    If you have installed any other customizations or addons then try removing those as well. Or for the purpose of troubleshooting try to reproduce it on a brand new installation of xenForo.
     

Share This Page