• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

Not a bug Special chars on URL

#1
Checking Xenforo more calmly found some interesting bugs ..

Friendly urls, are perfectly in the browser, but copying the link and paste it in the editor of the XF or even in Notepad the format of the url changes when you have special characters

Looking deeper into the generated page source, they have the same error code using special characters.

Source 1.jpg Source 2.jpg Source 3.jpg
There's more .. xD ... looking at the pages indexed in google, the links have the same error code.

It would be practical to remove the title pages of the urls, but the difference in the number of return visits and google adsense are great .. then there is the slightest possibility to disable the function ... it only remains to fix it

This is not a browser error, as it happens in IE,Firefox and Chrome..

Test special characters inXF
http://xenforo.com/community/threads/test-special-char-url-á-à-â-ã-ä.29602/

Now copy Link above and paste to XF Editor

I await a solution
 

mrGTB

Well-known member
#3
Works OK in my Editor, image below.

test-special-characters.png

Also works OK in my XF locahost install.

test-special-characters-xf-editor.png

Just did copy n paste job of the link from your first thread
 
#4
resolved:

After several attempts, enabled the romanization .. and it worked perfectly .. removed all the special characters ...

Edit library/Xenforo/Link.php

change this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = false)

to this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = true)
 

duydangle

Active member
#5
resolved:

After several attempts, enabled the romanization .. and it worked perfectly .. removed all the special characters ...

Edit library/Xenforo/Link.php

change this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = false)

to this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = true)
Can you show me the result?
 
#7
resolved:

After several attempts, enabled the romanization .. and it worked perfectly .. removed all the special characters ...

Edit library/Xenforo/Link.php

change this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = false)

to this
public static function buildIntegerAndTitleUrlComponent($integer, $title = '', $romanize = true)
I know this is old but it helped us to get special characters into friendly urls and now it's working perfectly!

Before this edit, there was a javascript error for whoever creates threads or posts with a special character like:
☠ ☮ ☯ ♠ Ω ♤ ♣ ♧ ♥ ♡ ♦ ♢ ♔ ♕ ♚ ♛ ⚜ ★ ☆ ✮ ✯ ☄ ☾ ☽ ☼ ☀ ☁ ☂ ☃ ☻ ☺ ☹ ۞ ۩
After the edit it is now possible to have special characters like that inside your post / thread title without any errors.

Thank you ;)