1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.4 Spam management not working as expected

Discussion in 'XenForo Questions and Support' started by Mr Lucky, Jun 19, 2015.

  1. Mr Lucky

    Mr Lucky Well-Known Member

    I have set registrations to be rejected with 2 SFS flags

    However I have a newly registered member awaiting manual approval, but the spam log shows three flags.

    Spam Log:
    • StopForumSpam matched (username: 2, email: 2, ip: 10)

    Shouldn't this have been automatically rejected?

    Screen Shot 2015-06-19 at 07.58.23.png
  2. Mike

    Mike XenForo Developer Staff Member

    There's a setting right below the screenshot of "Only count flags recorded at least this many times". It defaults to 5, so the username and email don't count as definitive flags, meaning only 1 was detected.
  3. Mr Lucky

    Mr Lucky Well-Known Member

    Is there a simpler way to explain that, or give some examples, or am I being a bit thick as I don't understand?
  4. Mike

    Mike XenForo Developer Staff Member

    The username and email were only recorded 2 times by SFS. The threshold defined by the option I mentioned defaults to 5, so they aren't "counted".
  5. Mr Lucky

    Mr Lucky Well-Known Member

    Thanks, that makes sense now. I took it to mean recorded by the spam manager, not SFS.

    maybe I am a bit thick.
  6. Joeychgo

    Joeychgo Well-Known Member

    We need a way to exclude the username as a flag. email and IP are good, username is a worthless medium. I just had a user rejected for having the username 'James'

Share This Page