• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 Spam management not working as expected

Mr Lucky

Well-known member
#1
I have set registrations to be rejected with 2 SFS flags

However I have a newly registered member awaiting manual approval, but the spam log shows three flags.

Spam Log:
  • StopForumSpam matched (username: 2, email: 2, ip: 10)

Shouldn't this have been automatically rejected?

Screen Shot 2015-06-19 at 07.58.23.png
 

Mike

XenForo developer
Staff member
#2
There's a setting right below the screenshot of "Only count flags recorded at least this many times". It defaults to 5, so the username and email don't count as definitive flags, meaning only 1 was detected.
 

Mr Lucky

Well-known member
#3
There's a setting right below the screenshot of "Only count flags recorded at least this many times". It defaults to 5, so the username and email don't count as definitive flags, meaning only 1 was detected.
Is there a simpler way to explain that, or give some examples, or am I being a bit thick as I don't understand?
 

Mike

XenForo developer
Staff member
#4
The username and email were only recorded 2 times by SFS. The threshold defined by the option I mentioned defaults to 5, so they aren't "counted".
 

Joeychgo

Well-known member
#6
We need a way to exclude the username as a flag. email and IP are good, username is a worthless medium. I just had a user rejected for having the username 'James'