• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.5 Spam emails, dead emails, inactive emails...

#1
Hey,

I have a forum I bought maybe around 4 years ago, unfortunately the old owners (who ran it on vBulletin) didn't have email validation, so everyone used dead emails.

I am looking to send out a mass email (I've done a few and the dead ones don't seem to go after the first email / no email cleanse????)

I want the dead emails out of the database, the database has over 40,000 people in it, so what would be the best method?

Thanks
Ross
 

Mike

XenForo developer
Staff member
#2
If you configure the email bounce handling system in the options and send the emails through the control panel, the bounces should be processed and the users' accounts will move to the email bounce state.
 
#3
If you configure the email bounce handling system in the options and send the emails through the control panel, the bounces should be processed and the users' accounts will move to the email bounce state.
Nope, doesn't seem to have done anything? Any chance you can take a look?
 

Mike

XenForo developer
Staff member
#5
Nope, doesn't seem to have done anything? Any chance you can take a look?
Are there entries in the email bounce log in the control panel? If not, then mail wasn't received in that account (or some other mail program read it first). We'll potentially need more details about your email sending and bounce setup.
 

Mike

XenForo developer
Staff member
#9
If there are mails in the account, then either XenForo isn't reading from that account or something else is collecting the mail (XF will only receive unread mail; if another account downloads it first, that may prevent XF from seeing it). Make sure you've set the proper credentials for reading from the bounce account and that no other program (or person!) reads from that account.
 
#13
Getting this error;


Server Error Log
Error Info
Zend_Mail_Protocol_Exception: cannot connect to host; error = php_network_getaddresses: getaddrinfo failed: Name or service not known (errno = 0 ) - library/Zend/Mail/Protocol/Imap.php:100
Generated By: Unknown Account, 4 minutes ago
Stack Trace
#0 /home/dvfwqmnd/public_html/library/Zend/Mail/Storage/Imap.php(273): Zend_Mail_Protocol_Imap->connect('mail.primeforum...', 993, 'SSL')
#1 /home/dvfwqmnd/public_html/library/XenForo/Model/EmailBounce.php(292): Zend_Mail_Storage_Imap->__construct(Array)
#2 /home/dvfwqmnd/public_html/library/XenForo/Deferred/EmailBounce.php(19): XenForo_Model_EmailBounce->openBounceHandlerConnection()
#3 /home/dvfwqmnd/public_html/library/XenForo/Model/Deferred.php(295): XenForo_Deferred_EmailBounce->execute(Array, Array, 7.99999880791, '')
#4 /home/dvfwqmnd/public_html/library/XenForo/Model/Deferred.php(429): XenForo_Model_Deferred->runDeferred(Array, 7.99999880791, '', false)
#5 /home/dvfwqmnd/public_html/library/XenForo/Model/Deferred.php(374): XenForo_Model_Deferred->_runInternal(Array, NULL, '', false)
#6 /home/dvfwqmnd/public_html/deferred.php(23): XenForo_Model_Deferred->run(false)
#7 {main}
Request State
array(3) {
["url"] => string(39) "http://www.primeforums.net/deferred.php"
["_GET"] => array(0) {
}
["_POST"] => array(4) {
["_xfRequestUri"] => string(29) "/admin.php?logs/email-bounces"
["_xfNoRedirect"] => string(1) "1"
["_xfToken"] => string(8) "********"
["_xfResponseType"] => string(4) "json"
}
}