• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.2 Some question for optimizing my forum

#1
Hi,
I have a few questions to ask yourself.

I want to replace my navigation bar that allows mounted and down the page as a bar like this. (Example: http://fr-modz.com)


then

I would like to know how to enable my logo header becomes transparant, but not all at once, I would like to see that progress towards transparancy to give you an example, flew over the logo of the site: http:// realitygaming.fr

then

I would like the menu tabs down the overview of our nickname is the small icon like this:


then

I would like my personal details on a message like this:
the places they appear like this:


then

I want my number message, I love ect. focus appears like this:
(With small logo at the beginning)

And finally,

I love the last post of a topic created appears as text with a tag like this

(This is the last post of a topic in the staff section, this allows faster editing the post rather than going into the template of the admin cp)
 

Tracy Perry

Well-known member
#3
Hi,
I have a few questions to ask yourself.
In other words, you would like someone to customize your style for you?
If so, then that request would fit appropriately in this section of the forum.
I would like the menu tabs down the overview of our nickname is the small icon like this:
This could have been found by doing simple research in the resources
http://xenforo.com/community/resources/fontawesome-icons-in-visitor-tab-account-wrapper.1861/


then

I want my number message, I love ect. focus appears like this:
(With small logo at the beginning)
And this could have been found at http://xenforo.com/community/resources/fontawesome-icons-in-message-user-info.1954/

And finally,

I love the last post of a topic created appears as text with a tag like this

(This is the last post of a topic in the staff section, this allows faster editing the post rather than going into the template of the admin cp)
Not really sure which part you are referring to (The Notice: or the icon beside it).
My suggestion is to research the forums to see if you find what you are looking for (as well as the resource manager) as most of this has been posted in one or the other. I will look a little further and see if i can find the links to refer you to for the other items.
 

Tracy Perry

Well-known member
#5
Haven't really had time to look through the resources and styling/customization forum.... been playing with a party in Black Ops 2 for the last couple of hours.
 

Tracy Perry

Well-known member
#8
On part one, when I go to the example site I see a standard bar at the top. If there is an option for registered users to move it to the side then it is probably an add-on and you need to contact the administrators of that site and inquire with them about it (it may be custom code).
On the second, I haven't really had time to research it as I have been working on getting my third forum set up and running. I'll see if I can find something out tonight after I wake up from my nap (it's 6:37am here). In the meantime, you may want to try some searches based upon the term messageuserinfo in the forum and resources.
 
#10
This did not help me.
I just want the Personal details of a user without their text displays such as here, delete the text "Playstation"
and is centered in the info bar of user logins., and below it is the same thing but with the contact details. and all with a border around it, as provided on the screen above.
 

Tracy Perry

Well-known member
#11
This did not help me.
I just want the Personal details of a user without their text displays such as here, delete the text "Playstation"
and is centered in the info bar of user logins., and below it is the same thing but with the contact details. and all with a border around it, as provided on the screen above.
Have you thought about asking the administrator of that site exactly what he has done. I'm not able to be do much right now as my ISP is still having problems (the heat is messing with the cable modem service) and am having to use the hotspot on my phone to access the site.
I'm doing something similar, but I have a multi-select option of Apple devices a user can choose. Depending upon which devices they choose it displays an icon for that device (it displays in the member profile just fine but it's putting a "," on the area you are referring to.
If you have a single item, then it would work just fine for it.
In the Custom User Fields on the third tab (General Options) I have the below in my HTML box
Code:
<div class="devices"><img src="images/devices/{$value}.png" /></div>
The $value corresponds to the option response that they select

1 iPhone
2 iPad
3 iPod
and displays the associated iPod/iPad/iPhone.png file.
If you used something similar with a single option it would probably work.
 
Last edited:

Brogan

XenForo moderator
Staff member
#12
To remove a custom profile field title, add to EXTRA.css:
Code:
.messageUserBlock .extraUserInfo dl.userField_custom_field_name dt {
display: none !important;
}
Change the text in red as required.
 

Tracy Perry

Well-known member
#13
To remove a custom profile field title, add to EXTRA.css:
Code:
.messageUserBlock .extraUserInfo dl.userField_custom_field_name dt {
display: none !important;
}
Change the text in red as required.
@Brogan, maybe you can point me to something similar as it's driving me crazy. I use a multiple choice drop down selection and use the code I related above to display the image. In the members profile it does fine, but on the forum extraUserInfo it displays several commas off to the right of the images (example image attached). Any idea how to get rid of that?
example.png
 

Tracy Perry

Well-known member
#17
It seems to be related to the comma (,) that is separating the images.
Yep. Normally those would be text entries (which the comma would be normal & acceptable), but since I over-ride the text with the images via the HTML statement it still puts the images in (just not separated themselves by the comma's). I've got a feeling it's more a limitation on how that is coded to display multi-choice drop downs than anything and can't be fixed. Weird thing is in the members profile Information tab it displays without them <shrugs shoulders>. I'll just keep them disabled in the ExtraUserInfo - altho it would be nice to be able to use them. Thanks!
 

Jeremy

Well-known member
#18
@Tracy Perry:

If you want to match this for each of your styles, if you make the text color using the CSS selector above the same as the background for the user info, they'll appear by won't display. ;)

Its caused by the fact that the message_user_info uses a template helper, while the profile page uses a template.