1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

XF 1.2 Some question for optimizing my forum

Discussion in 'Styling and Customization Questions' started by NGS, Jul 7, 2013.

  1. NGS

    NGS Member

    Hi,
    I have a few questions to ask yourself.

    I want to replace my navigation bar that allows mounted and down the page as a bar like this. (Example: http://fr-modz.com)
    [​IMG]

    then

    I would like to know how to enable my logo header becomes transparant, but not all at once, I would like to see that progress towards transparancy to give you an example, flew over the logo of the site: http:// realitygaming.fr

    then

    I would like the menu tabs down the overview of our nickname is the small icon like this: [​IMG]

    then

    I would like my personal details on a message like this: [​IMG] the places they appear like this: [​IMG]

    then

    I want my number message, I love ect. focus appears like this: [​IMG] (With small logo at the beginning)

    And finally,

    I love the last post of a topic created appears as text with a tag like this [​IMG]
    (This is the last post of a topic in the staff section, this allows faster editing the post rather than going into the template of the admin cp)
     
  2. NGS

    NGS Member

    Help me please.
     
  3. Tracy Perry

    Tracy Perry Well-Known Member

    In other words, you would like someone to customize your style for you?
    If so, then that request would fit appropriately in this section of the forum.
    This could have been found by doing simple research in the resources
    http://xenforo.com/community/resources/fontawesome-icons-in-visitor-tab-account-wrapper.1861/


    And this could have been found at http://xenforo.com/community/resources/fontawesome-icons-in-message-user-info.1954/

    Not really sure which part you are referring to (The Notice: or the icon beside it).
    My suggestion is to research the forums to see if you find what you are looking for (as well as the resource manager) as most of this has been posted in one or the other. I will look a little further and see if i can find the links to refer you to for the other items.
     
  4. NGS

    NGS Member

    Thanks,
    Do you have an answer for this:

    And this :

     
  5. Tracy Perry

    Tracy Perry Well-Known Member

    Haven't really had time to look through the resources and styling/customization forum.... been playing with a party in Black Ops 2 for the last couple of hours.
     
  6. NGS

    NGS Member

    You ave finish ?
     
  7. NGS

    NGS Member

    Up, help me please.
     
  8. Tracy Perry

    Tracy Perry Well-Known Member

    On part one, when I go to the example site I see a standard bar at the top. If there is an option for registered users to move it to the side then it is probably an add-on and you need to contact the administrators of that site and inquire with them about it (it may be custom code).
    On the second, I haven't really had time to research it as I have been working on getting my third forum set up and running. I'll see if I can find something out tonight after I wake up from my nap (it's 6:37am here). In the meantime, you may want to try some searches based upon the term messageuserinfo in the forum and resources.
     
  9. Tracy Perry

    Tracy Perry Well-Known Member

  10. NGS

    NGS Member

    This did not help me.
    I just want the Personal details of a user without their text displays such as here, delete the text "Playstation" [​IMG] and is centered in the info bar of user logins., and below it is the same thing but with the contact details. and all with a border around it, as provided on the screen above.
     
  11. Tracy Perry

    Tracy Perry Well-Known Member

    Have you thought about asking the administrator of that site exactly what he has done. I'm not able to be do much right now as my ISP is still having problems (the heat is messing with the cable modem service) and am having to use the hotspot on my phone to access the site.
    I'm doing something similar, but I have a multi-select option of Apple devices a user can choose. Depending upon which devices they choose it displays an icon for that device (it displays in the member profile just fine but it's putting a "," on the area you are referring to.
    If you have a single item, then it would work just fine for it.
    In the Custom User Fields on the third tab (General Options) I have the below in my HTML box
    Code:
    <div class="devices"><img src="images/devices/{$value}.png" /></div>
    The $value corresponds to the option response that they select

    1 iPhone
    2 iPad
    3 iPod
    and displays the associated iPod/iPad/iPhone.png file.
    If you used something similar with a single option it would probably work.
     
    Last edited: Jul 13, 2013
  12. Brogan

    Brogan XenForo Moderator Staff Member

    To remove a custom profile field title, add to EXTRA.css:
    Code:
    .messageUserBlock .extraUserInfo dl.userField_custom_field_name dt {
    display: none !important;
    }
    Change the text in red as required.
     
  13. Tracy Perry

    Tracy Perry Well-Known Member

    @Brogan, maybe you can point me to something similar as it's driving me crazy. I use a multiple choice drop down selection and use the code I related above to display the image. In the members profile it does fine, but on the forum extraUserInfo it displays several commas off to the right of the images (example image attached). Any idea how to get rid of that?
    example.png
     
  14. Brogan

    Brogan XenForo Moderator Staff Member

    The image is too small to see any detail, can you link me to the site so I can check the source code?
     
  15. Tracy Perry

    Tracy Perry Well-Known Member

    http://sayapple.com/threads/evasi0n-jailbreak-released.1522/ will take you directly to the post. It's the images of the different Apple products and out to the right of the top is 3 commas (like what would be displayed to separate the text fields that would normally display.
     
  16. Brogan

    Brogan XenForo Moderator Staff Member

    It seems to be related to the comma (,) that is separating the images.
     
  17. Tracy Perry

    Tracy Perry Well-Known Member

    Yep. Normally those would be text entries (which the comma would be normal & acceptable), but since I over-ride the text with the images via the HTML statement it still puts the images in (just not separated themselves by the comma's). I've got a feeling it's more a limitation on how that is coded to display multi-choice drop downs than anything and can't be fixed. Weird thing is in the members profile Information tab it displays without them <shrugs shoulders>. I'll just keep them disabled in the ExtraUserInfo - altho it would be nice to be able to use them. Thanks!
     
  18. Jeremy

    Jeremy XenForo Moderator Staff Member

    @Tracy Perry:

    If you want to match this for each of your styles, if you make the text color using the CSS selector above the same as the background for the user info, they'll appear by won't display. ;)

    Its caused by the fact that the message_user_info uses a template helper, while the profile page uses a template.
     
    Tracy Perry likes this.
  19. NGS

    NGS Member

    Thanks you brogan, now I'd like to view personal details on the same line
    http://prntscr.com/1f59me
     
  20. Jeremy

    Jeremy XenForo Moderator Staff Member

    Untested, but try adding float: left; to each of the definitions, since that display is correct,
     

Share This Page