• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 [SOLVED] The server responded with an error. The error message is in the JavaScript console.

Nuno

Active member
#1
Hi,

When I click in a username to see the profile page I get this error (as a guest or member):

"The following error occurred
The server responded with an error. The error message is in the JavaScript console."

There is no errors in the XF logs neither server/php logs.

This is what I see in the FF console:

Code:
XenForo.activate(%o) [object HTMLDocument] xenforo.js:220
"XenForo.init() 75ms. jQuery 1.11.0/1.2.8-dev" xenforo.js:209:168
"OverlayLoader for members/nuno.1/?card=1" xenforo.js:286:91
"PHP <!DOCTYPE html>
<html id="XenForo" lang="pt-PT" dir="LTR" class="Public NoJs LoggedIn NoSidebar  Responsive" xmlns:fb="http://www.facebook.com/2008/fbml">
<head>

    <meta charset="utf-8" />
    <meta http-equiv="X-UA-Compatible" content="IE=Edge,chrome=1" />
   
        <meta name="viewport" content="width=device-width, initial-scale=1" />
   
   
        <base href="http://www.domain.com/" />
        <script>
            var _b = document.getElementsByTagName('base')[0], _bH = "http://www.domain.com/";
            if (_b && _b.href != _bH) _b.href = _bH;
        </script>
   

    <title>Nuno | XenForo</title>
   
    <noscript><style>.JsOnly, .jsOnly { display: none !important; }</style></noscript>
    <link rel="stylesheet" href="css.php?css=xenforo,form,public&amp;style=1&amp;dir=LTR&amp;d=1433668739" />
    <link rel="stylesheet" href="css.php?css=member_view,message_simple,moderator_bar&amp;style=1&amp;dir=LTR&amp;d=1433668739" />
   
   

   
        <script src="js/jquery/jquery-1.11.0.min.js"></script>   
       
    <script src="js/xenforo/xe"[…] xenforo.js:231:168

XenForo.activate(%o) [object Object] xenforo.js:220
An help?

Thanks
 

Nuno

Active member
#2
Solved

I had this in nginx:

Code:
try_files $uri $uri/ /index.php;
... and should be:

Code:
try_files $uri $uri/ /index.php?$uri&$args;