• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.4 [SOLVED : Rebuild user cache] Group User Name CSS issue ?

Ghostaunt

Active member
#1
Hello,

I think there is an issue with the User Name CSS groups.
I have an user with this groups :

User settings :
Primary :
  1. Forum member
Secondary :
  1. Member of Exodia
  2. Member of LoL

Groups priority :
  1. Member of LoL
    Priority : 20
    User Name CSS : color: red;

  2. Member of Exodia
    Priority : 0
    User name CSS : (empty)

  3. Forum member
    Priority : 0
    User name CSS : (empty)

And it doesn't work... The user has any style propertie (and any class style)..
But if I set a color in the group 'Member of Exodia', I see the color on his nickname...

What's wrong ?
Can you help me please ?
 
Last edited:
#4
Your settings appear correct.

Try editing/saving the user via the Admin CP, or rebuild all user info after changing the groups:

Admin CP -> Tools -> Rebuild Caches -> Rebuild User Caches
I keep trying this but it's not working.

Applied css as normal, increased display priority to 1, rebuilt user cache, nothing. Checked everything simple but nothing works.

What am I missing?
 

Mike

XenForo developer
Staff member
#5
That would likely imply that there's still another priority value that's higher, or you're checking a place where the rich values aren't displayed. (Looking at a post should be sufficient. Ensure you're testing on the default style though to eliminate that as a variable.) Look at all of the groups the user is a member of and confirm that the priority value for the group you want is the highest.
 
#6
That would likely imply that there's still another priority value that's higher, or you're checking a place where the rich values aren't displayed. (Looking at a post should be sufficient. Ensure you're testing on the default style though to eliminate that as a variable.) Look at all of the groups the user is a member of and confirm that the priority value for the group you want is the highest.
I found another usergroup with higher priority, increased priority on custom usergroup, rebuilt user cache, checked on default style, still nothing. :(