• This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn more.

XF 1.1 slow in personal conversation

AndreaMarucci

Well-known member
#1
I've noticed that XF is slow inside the personal conversations when you post a message. What happen is that you click on post and you've to wait some time before the post get posted. Consequence of this is that often the user click another time and the msg get posted two times. This happen if the PC has many posts but often also if the PC has a small number of posts...
 

MattW

Well-known member
#3
How is your board set to send e-mails out?

Try adding this to your config file and see if the delay is still there:

Code:
$config['enableMail'] = 0;
 

Chris D

XenForo developer
Staff member
#4
Andrea,

When I was logged on to your site yesterday debugging that add-on, I did notice that there were some e-mail related errors in the Server Error Log.

You may want to check these out. I didn't say anything yesterday as I just assumed you knew.
 

AndreaMarucci

Well-known member
#6
Cheched now and found many of these errors. What can I do? Give 777 permission to Abstract.php?

Code:
Zend_Mail_Protocol_Exception: 5.7.1 Access denied - library/Zend/Mail/Protocol/Abstract.php:431
Generated By: giancarlo, Yesterday at 2:56 PM
 
#0 library/Zend/Mail/Protocol/Smtp.php(205): Zend_Mail_Protocol_Abstract->_expect(220, 180)
#1 library/Zend/Mail/Transport/Smtp.php(200): Zend_Mail_Protocol_Smtp->helo('localhost')
#2 library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#3 library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#4 library/XenForo/Mail.php(170): Zend_Mail->send()
#5 library/XenForo/Mail.php(145): XenForo_Mail->sendMail(Object(Zend_Mail))
#6 library/XenForo/Mail.php(197): XenForo_Mail->send('battaglia.giaco...', 'Giabat', Array, '', '', '')
#7 library/XenForo/Model/Conversation.php(855): XenForo_Mail->queue('battaglia.giaco...', 'Giabat')
#8 library/PremiumBBcode/Model/Conversation.php(32): XenForo_Model_Conversation->insertConversationAlert(Array, Array, 'reply', Array, Array, Array)
#9 library/XenForo/Model/Conversation.php(712): PremiumBBcode_Model_Conversation->insertConversationAlert(Array, Array, 'reply', Array, Array, Array)
#10 /library/Tapatalk/Push/Conversation.php(35): XenForo_Model_Conversation->addConversationReplyToRecipients(Array, Array, Array)
#11 /library/XenForo/DataWriter.php(1385): Tapatalk_Push_Conversation->_postSave()
#12 /library/XenForo/DataWriter/ConversationMessage.php(144): XenForo_DataWriter->save()
#13 /library/XenForo/DataWriter.php(1385): XenForo_DataWriter_ConversationMessage->_postSave()
#14 /library/XenForo/ControllerPublic/Conversation.php(858): XenForo_DataWriter->save()
#15 /library/PostsConversation/ControllerPublic/Conversation.php(50): XenForo_ControllerPublic_Conversation->actionInsertReply()
#16 /library/XenForo/FrontController.php(310): PostsConversation_ControllerPublic_Conversation->actionInsertReply()
#17 /library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#18 /index.php(13): XenForo_FrontController->run()
#19 {main}
 

AndreaMarucci

Well-known member
#7
Also some of these errors

Code:
Zend_Mail_Protocol_Exception: A valid session has not been started - library/Zend/Mail/Protocol/Smtp.php:257
Generated By: gherardo, Today at 3:17 PM
 
Stack Trace
#0 /library/Zend/Mail/Transport/Smtp.php(207): Zend_Mail_Protocol_Smtp->mail('webmaster@kog.i...')
#1 /library/Zend/Mail/Transport/Abstract.php(348): Zend_Mail_Transport_Smtp->_sendMail()
#2 /library/Zend/Mail.php(1194): Zend_Mail_Transport_Abstract->send(Object(Zend_Mail))
#3 /library/XenForo/Mail.php(170): Zend_Mail->send()
#4 /library/XenForo/Mail.php(145): XenForo_Mail->sendMail(Object(Zend_Mail))
#5 /library/XenForo/Mail.php(197): XenForo_Mail->send('corrado_toxiri@...', 'Corrado68', Array, '', '', '')
#6 /library/XenForo/Model/ThreadWatch.php(234): XenForo_Mail->queue('corrado_toxiri@...', 'Corrado68')
#7 /library/PremiumBBcode/Model/ThreadWatch.php(19): XenForo_Model_ThreadWatch->sendNotificationToWatchUsersOnReply(Array, NULL, Array)
#8 /library/XenForo/DataWriter/DiscussionMessage/Post.php(108): PremiumBBcode_Model_ThreadWatch->sendNotificationToWatchUsersOnReply(Array, NULL, Array)
#9 /library/WidgetFramework/Extend/DataWriter/DiscussionMessage/Post.php(4): XenForo_DataWriter_DiscussionMessage_Post->_postSaveAfterTransaction()
#10 /library/bdTagMe/XenForo/DataWriter/DiscussionMessage/Post.php(28): WidgetFramework_Extend_DataWriter_DiscussionMessage_Post->_postSaveAfterTransaction()
#11 /library/XenForo/DataWriter.php(1399): bdTagMe_XenForo_DataWriter_DiscussionMessage_Post->_postSaveAfterTransaction()
#12 /library/XenForo/ControllerPublic/Thread.php(504): XenForo_DataWriter->save()
#13 /library/XenForo/FrontController.php(310): XenForo_ControllerPublic_Thread->actionAddReply()
#14 /library/XenForo/FrontController.php(132): XenForo_FrontController->dispatch(Object(XenForo_RouteMatch))
#15 /index.php(13): XenForo_FrontController->run()
#16 {main}